Opened 8 years ago

Closed 8 years ago

#5841 closed Bug (fixed)

Transmission-Qt UNABLE to scan the watch folder at start.

Reported by: ValentinJesse Owned by: mike.dld
Priority: Normal Milestone: 2.90
Component: Qt Client Version: 2.84
Severity: Normal Keywords:
Cc:

Description

Hi! If i close Transmission Qt-Win / Add a new .torrent in the watch folder / And then start Transmission = It doesn't recognize the newly added torrent/torrents...

However, if i go on Preference/Downloading? and UNCHECK/CHECK "Automatically add .torrent files from:" it recognizes the torrents and works perfectly.

Very frustrating, because i have set up an Dropbox watch folder in which i put all my torrents while i'm on the go and if i start the computer and then Transmission, it doesn't pick the torrents automatically.

To make it short: 1 - Adding the torrent in the watch folder while the application is opened = SUCCESS 2 - Adding the torrent in the watch folder and then starting the application = FAILURE ( fixable only with the unchecking/checking the box i was writing about above) Win7 64bit Used the 64bit versions of Transmission. I have the same problem with 2.77 too

Made a video showing the problem http://i.imgur.com/vnV84Hw.gif

Change History (5)

comment:1 follow-up: Changed 8 years ago by rb07

  • Component changed from Transmission to Qt Client
  • Owner set to jordan
  • Summary changed from Transmission-Qt-Win 2.84/2.83/2.77 etc UNABLE to scan the watch folder. to Transmission-Qt UNABLE to scan the watch folder at start.

The version and the OS is not relevant.

The problem is very simple, the watch directory is scanned before the (local) session is created.

comment:2 Changed 8 years ago by ValentinJesse

Thank you for the prompt response. This is the only thing that keeps me away from using Transmission. Is this behavior fixable ?

comment:3 in reply to: ↑ 1 Changed 8 years ago by cfpp2p

Replying to rb07:

Component changed from Transmission to Qt Client

Owner set to jordan

Summary changed from Transmission-Qt-Win 2.84/2.83/2.77 etc UNABLE to scan the watch folder. to Transmission-Qt UNABLE to scan the watch folder at start.

The version and the OS is not relevant.

The problem is very simple, the watch directory is scanned before the (local) session is created.

To be clear, the problem does not exhibit itself with the daemon. Torrents added to the watch directory when the daemon is stopped are correctly added when the daemon is started.

comment:4 Changed 8 years ago by mike.dld

  • Owner changed from jordan to mike.dld
  • Status changed from new to assigned

comment:5 Changed 8 years ago by mike.dld

  • Milestone changed from None Set to 2.90
  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r14375, thanks for reporting.

Note: See TracTickets for help on using tickets.