Opened 6 years ago

Closed 6 years ago

#5879 closed Enhancement (wontfix)

Allow to close after the torrent is complete.

Reported by: duskCoder Owned by:
Priority: Normal Milestone: None Set
Component: CLI Version: 2.84
Severity: Normal Keywords:
Cc:

Description

In case we do not need seeding, it is sometimes useful that transmission-cli closes itself as soon as the download is complete (so we can, for instance, restart it with another torrent file).

Although the option

-f, --finish script

may be used to achieve that purpose, it is quite cumbersome. (we need to do something like killing the current instance of transmission-cli and restart it afterwards).

I propose to add this option:

-c, --close-on-finished

which closes the client when the torrent finishes.

use-case example:

$ transmission-cli -c file1.torrent && transmission-cli -c file2.torrent && poweroff

I attach a patch which may be used if the issue is accepted.

Attachments (1)

close_on_complete.diff (2.9 KB) - added by duskCoder 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by duskCoder

comment:1 Changed 6 years ago by mike.dld

  • Resolution set to wontfix
  • Status changed from new to closed

Transmission-cli is deprecated and its use is discouraged. If you want to download torrents without seeding, there are other options out there.

Note: See TracTickets for help on using tickets.