Opened 6 years ago

Closed 6 years ago

#5895 closed Enhancement (duplicate)

rpc: allow to listen on UNIX domain socket

Reported by: ibukanov Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.84
Severity: Normal Keywords:
Cc:

Description

Currently I expose transmission RPC interface over ssh to allow secure and passwordless authentication. However, as the transmission RPC port is exposed to every process in the system, this is not ideal. It would ve nice if transmission could listen on UNIX domain socket. Then I can restrict access to the socket using filesystem permissions and then use ssh socket forwarding to let remote clients to access RPC.

Change History (2)

comment:1 Changed 6 years ago by mike.dld

Curl "added support for HTTP over unix domain sockets, via CURLOPT_UNIX_SOCKET_PATH and --unix-socket" in 7.40.0.

comment:2 Changed 6 years ago by mike.dld

  • Resolution set to duplicate
  • Status changed from new to closed

Actually, duplicate of #5265.

Note: See TracTickets for help on using tickets.