Opened 6 years ago

Last modified 6 years ago

#5919 reopened Enhancement

should show progress bar and ETA estimation when setting/moving data new location

Reported by: morph Owned by:
Priority: Low Milestone: None Set
Component: GTK+ Client Version: 2.84
Severity: Normal Keywords:
Cc:

Description

Hello, this bug was originally reported at https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=608514 :

In transmission-gtk one can move torrent to other location than current,
and in the same time move data there. Currently after accepting changes,
transmission shows dialog:

Moving "xyz".
It can take a while....
(and disabled "Close" button)

Why not show progress bar which will be proportional to bytes of transfered
data,
relative to bytes of data which will be transfered (transmission knows or can
easly
compute this). Also time of ramaining transfer would be usefull.

Other problem is that torrent can be moved only one by one,
and before moving next, one need to wait to first to finish moving.
This also suggest progress bar will improve somehow situation
by allowing user know when it can move next torrent.
Moving multiple torrents, or not blocking whole GUI when moving one of torrents
is also good option.

Change History (2)

comment:1 Changed 6 years ago by x190

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5847.

comment:2 Changed 6 years ago by x190

  • Component changed from Transmission to GTK+ Client
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Re-opening this ticket, as this request is for transmission-gtk, while #5847 is for the Mac Client.

Note: See TracTickets for help on using tickets.