Opened 3 years ago

Closed 18 months ago

#5921 closed Bug (fixed)

Transition to libsystemd-dev

Reported by: morph Owned by: mike.dld
Priority: Normal Milestone: 3.00
Component: Transmission Version: 2.84
Severity: Normal Keywords:
Cc:

Description

Hello, in Debian we just applied this patch: http://anonscm.debian.org/cgit/collab-maint/transmission.git/diff/debian/patches/transition_to_libsystemd.patch?id=fd2b694dd91c7260646f96ff973f15c3b614dd31 (also attached)

The reason is that all the -dev systemd packages (at least in Debian, I'm unsure if this is a global migration) were merge into a single libsystemd-dev

Attachments (1)

transition_to_libsystemd.patch (1.5 KB) - added by morph 3 years ago.

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by morph

comment:1 Changed 20 months ago by floppymaster

I'm applying the same change for Gentoo. It would be nice to see this added upstream.

This does mean that at least systemd-209 or higher is required for building.

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5d45c75941a5fd40b933e9f9d04d9dc9f25dcaf6

comment:2 Changed 20 months ago by mike.dld

  • Milestone changed from None Set to 3.00
  • Owner set to mike.dld
  • Status changed from new to assigned

comment:3 Changed 18 months ago by mike.dld

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r14733, thanks!

Note: See TracTickets for help on using tickets.