Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#5930 closed Bug (fixed)

Fix style of Gtk+3.16 overshoot and undershoot

Reported by: nagisa Owned by: mike.dld
Priority: Normal Milestone: 2.90
Component: GTK+ Client Version: 2.84
Severity: Normal Keywords:
Cc:

Description

Our .tr-workarea style interferes with drawing undershoot and overshoot indicators which were added in 3.16. This patch fixes it.

Attachments (1)

style.patch (784 bytes) - added by nagisa 6 years ago.
Style patch

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by nagisa

Style patch

comment:1 Changed 6 years ago by mike.dld

I've checked the patch with GTK+ 3.14.6 and 3.14.10 and it looks fine (meaning, no visual changes I can spot). Could you (or someone else) confirm that it works for GTK+ versions down to 3.4 (that's the minimum we support at the moment)?

comment:2 Changed 6 years ago by mike.dld

  • Owner changed from jordan to mike.dld
  • Status changed from new to assigned

comment:3 Changed 6 years ago by mike.dld

  • Resolution set to fixed
  • Status changed from assigned to closed

Committed as r14519. I've change border-width so that only left and right borders are set since I don't like that 1px for top/bottom. See if it still works for you well (it does for me).

comment:4 Changed 6 years ago by mike.dld

  • Milestone changed from None Set to 2.90

comment:5 Changed 5 years ago by mike.dld

Closed #6044 as duplicate of this ticket.

Note: See TracTickets for help on using tickets.