Opened 6 years ago

Closed 6 years ago

#5937 closed Bug (fixed)

Removing a duplicate torrent causes a crash

Reported by: xzcvczx Owned by: mike.dld
Priority: Normal Milestone: 2.90
Component: libtransmission Version: 2.80
Severity: Normal Keywords:
Cc:

Description

If you add a duplicate torrent through the WebUI (either by address or uploading a torrent file) the transmission GUI will show the torrent existing twice, if you remove from list one of the duplicates then transmission will crash,

If you attempt to add a duplicate in the transmission gui itself it will detect duplicates and ignore/warn the user that it is a duplicate (either by address or torrent file)

I have tested this in 2.8.4 and the trunk version of transmission for Mac on 10.10.3

This also occurs on Transmission 2.8.2 provided with ubuntu 14.04

Attachments (2)

Transmission_2015-04-28-170259_Simons-MacBook-Air.crash (64.9 KB) - added by xzcvczx 6 years ago.
DiagnosticReport? OSX
rpc_duplicate_fix.diff (645 bytes) - added by xzcvczx 6 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by mike.dld

  • Version changed from 2.84+ to 2.82

comment:2 Changed 6 years ago by mike.dld

Also mentioned in ticket:4682#comment:7 where the issue seems to be originating from (r14077).

Changed 6 years ago by xzcvczx

comment:3 Changed 6 years ago by mike.dld

  • Component changed from Transmission to libtransmission
  • Owner set to mike.dld
  • Status changed from new to assigned
  • Version changed from 2.82 to 2.80

comment:4 Changed 6 years ago by mike.dld

Comitted as r14517. I didn't include the second part as it changes behavior: result reported from RPC changes from "success" (success) to "duplicate torrent" (error). It was actually reported as error up until 2.81, where things changed with r14116.

comment:5 Changed 6 years ago by mike.dld

Closed #5536 as duplicate of this ticket.

comment:6 Changed 6 years ago by mike.dld

  • Milestone changed from None Set to 2.90
  • Resolution set to fixed
  • Status changed from assigned to closed

Closing as there are #5614 and #5640 dealing with success/error change.

Note: See TracTickets for help on using tickets.