Opened 6 years ago

Closed 6 years ago

#5959 closed Bug (duplicate)

crash on quit on 2.84, crash on use on night build

Reported by: Dowser101 Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.84
Severity: Normal Keywords: crash OSX 2.84
Cc:

Description

Hi, i m using a MacMini? with i5 CPU, OS X 10.9.5 and Transmission latest release and i do have a slight problem as this version crashes on quit. I did try the latest night build and found it crashed in the morning (while running). The crash logs are pretty long and i guess only a part is valuable, what should i join to help the staff? Here is the beginning and the thread crash section of the 2.84 release version crash log:

Process: Transmission [30171] Path: /Applications/Transmission?.app/Contents/MacOS/Transmission Identifier: org.m0k.transmission Version: 2.84+ (14535) Code Type: X86-64 (Native) Parent Process: launchd [486] Responsible: Transmission [30171] User ID: 502

Date/Time?: 2015-06-02 04:06:09.476 +0200 OS Version: Mac OS X 10.9.5 (13F1077) Report Version: 11 Anonymous UUID: 51A25AB2-FD33-EC7D-889C-0B794564C1DF

Crashed Thread: 2

Exception Type: EXC_BAD_ACCESS (SIGSEGV) Exception Codes: EXC_I386_GPFLT

(...)

Thread 2 Crashed: 0 org.m0k.transmission 0x00000001000c78e8 evdns_cancel_request + 82 1 org.m0k.transmission 0x00000001000cb0c3 evdns_getaddrinfo_cancel + 81 2 org.m0k.transmission 0x00000001000a051a tau_tracker_free + 37 3 org.m0k.transmission 0x000000010007b8bb tr_ptrArrayForeach + 62 4 org.m0k.transmission 0x000000010007b831 tr_ptrArrayDestruct + 41 5 org.m0k.transmission 0x00000001000a04e0 tr_tracker_udp_close + 44 6 org.m0k.transmission 0x00000001000691f0 sessionCloseImpl + 335 7 org.m0k.transmission 0x000000010007c2d3 readFromPipe + 323 8 org.m0k.transmission 0x00000001000b6d62 event_base_loop + 1827 9 org.m0k.transmission 0x000000010007befa libeventThreadFunc + 141 10 org.m0k.transmission 0x0000000100072719 ThreadFunc? + 15 11 libsystem_pthread.dylib 0x00007fff8ff63899 _pthread_body + 138 12 libsystem_pthread.dylib 0x00007fff8ff6372a _pthread_start + 137 13 libsystem_pthread.dylib 0x00007fff8ff67fc9 thread_start + 13

I hope that may help

D.

Change History (1)

comment:1 Changed 6 years ago by mike.dld

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5891.

Note: See TracTickets for help on using tickets.