Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6005 closed Enhancement (fixed)

Force to check openssl min. version of 0.9.8b when building with '--with-crypto=openssl'

Reported by: tals Owned by: mike.dld
Priority: Low Milestone: 2.90
Component: libtransmission Version: 2.84+
Severity: Normal Keywords:
Cc:

Description

When building with

'--with-crypto=openssl'

and openSSL version < 0.9.8b the following error occurs:

implicit declaration of function 'EVP_CIPHER_CTX_new'

Change History (3)

comment:1 Changed 6 years ago by mike.dld

  • Owner changed from jordan to mike.dld
  • Status changed from new to assigned

comment:2 Changed 6 years ago by mike.dld

  • Milestone changed from None Set to 2.90
  • Resolution set to fixed
  • Status changed from assigned to closed

I wasn't able to build unpatched 0.9.4 (which is currently set as minimum supported version), 0.9.5 and 0.9.6 with recent GCC.

Bumping minimum supported version to 0.9.7. Added fallback implementation for EVP_CIPHER_CTX_new and EVP_CIPHER_CTX_free for versions less than 0.9.8b. See r14575.

Thanks for reporting.

comment:3 Changed 6 years ago by tals

Thanks! Works for me.

Note: See TracTickets for help on using tickets.