Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#6010 closed Bug (invalid)

Verifying local data fails on files with some non-ASCII characters in their names

Reported by: Golffies Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.84
Severity: Normal Keywords: non-ASCII diacritic verification
Cc:

Description

Context:

  • torrent includes files having Polish (non-ASCII) characters in their names
  • torrent file has been created with Transmission 2.84 on a host running OS X and imported to Transmission 2.52 on a server running Debian.
  • the torrent has to be seeded by Transmission 2.52, not leeched.
  • content files have then been copied to the mass storage of the server running Transmission 2.52, not using transmission itself to locally create the files.

Actual behaviour:

Before starting to seed, when verifying the local files with Transmission 2.52, verification fails on nearly each file whose name contains at least one Polish (non-ASCII) character. However, this is not true for all Polish characters. Character "ł" does not disturb Transmission 2.52. See attached screenshot.

Expected behaviour:

Verification of the local content files with Transmission 2.52 is expected to be successful as these files are the exact copy of those which the torrent file was created on.

Attachment:

Screenshot of Transmission web UI showing part of the files verified properly and part of them whom verification failed.

Attachments (3)

Transmission Web Interface.png (58.3 KB) - added by Golffies 6 years ago.
Screenshot of Transmission Web Interface
Zazolc gesla jazn.png (62.1 KB) - added by Golffies 5 years ago.
Zazolc gesla jazn.txt (63 bytes) - added by Golffies 5 years ago.

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by Golffies

Screenshot of Transmission Web Interface

comment:1 Changed 6 years ago by mike.dld

  • Resolution set to incomplete
  • Status changed from new to closed

Hopefully you realize that 2.52 is a 3+ years old version and no one is going to fix it. Please install 2.82 or 2.84 (I know those are available in Debian repositories; building from source is always an option too) and see if issue persists. Reopen if necessary.

comment:2 Changed 6 years ago by Golffies

  • Resolution incomplete deleted
  • Status changed from closed to reopened
  • Version changed from 2.52 to 2.84

We upgraded to Transmission 2.84 on the Debian server. The issue persists.

comment:3 Changed 6 years ago by mike.dld

If you let Transmission download those missing files, are they created alongside the existing ones or overwrite them? What I'm trying to understand is could it be possible that filenames encoding was somehow broken during the files transfer.

comment:4 Changed 6 years ago by mike.dld

And since you are mentioning Mac, could it be related to #5616?

comment:5 Changed 5 years ago by mike.dld

@Golffies, anything to add?..

comment:6 Changed 5 years ago by Golffies

  • Resolution set to invalid
  • Status changed from reopened to closed

Hi Mike,

after further investigating, I have to apologise for having reported a bug which was not related to transmission but to the file management web app which we used. That old version of Ajaxplorer was translating diacritics without any warning to the user, then actually changing the name of the files ! Looking at the list of files in the repository from a shell, it was not possible to see any difference (see the attached screenshot and test text file : Zażółć gęślą jaźń.png and Zażółć gęślą jaźń.txt).

Sorry for my mistake. Cheers.

comment:7 Changed 5 years ago by mike.dld

The files didn't make it through for some reason. Please reattach for the sake of completeness.

Changed 5 years ago by Golffies

Changed 5 years ago by Golffies

comment:8 Changed 5 years ago by Golffies

Sounds like a bug in Trac prevents to attach the files Zażółć gęślą jaźń.png and Zażółć gęślą jaźń.txt but let it to be done for the files Zazolc gesla jazn.png and Zazolc gesla jazn.txt. Additionally, I failed to report the very bug, as the url I have been directed to do so failed to open. Anyway, this is another matter.

comment:9 Changed 5 years ago by Golffies

BTW, there is a strong chance that the whole mess is related to NFD (Mac) vs NFC (Linux) Unicode character encoding standards, as you pointed out when directing me to bug #5616. You were right. I had no idea that such an issue may arise between platforms, all of them being "unicode compliant". At that point, my best guess is that Ajaxplorer wrote on the Debian host files' names following NFD standard, when rsync transcoded files' name from NFD to NFC during the copy process.

At first glance, it looked like Ajaxplorer made some changes to the files' name, which is likely a wrong statement. It actually failed to convert from NFD to NFC.

Those few words added "for the sake of completeness" as you said. :-)

Note: See TracTickets for help on using tickets.