Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6015 closed Bug (invalid)

Dual Monitor setup - When I switch off one, the Qt client disappears

Reported by: burianvlastimil Owned by: jordan
Priority: Normal Milestone: None Set
Component: Qt Client Version: 2.84
Severity: Normal Keywords: dual monitor
Cc: burian.vlastimil2@…

Description

I have a setup of two screens.
http://i67.tinypic.com/akvmty.png
The left one is a display port monitor 2560x1440.
The right one is a laptop screen 1920x1080.
The left one is primary.

The bug is easily reproduced. When I switch off the primary (left) screen, the Qt client disappears with its icon in system tray. But it is always running in the background. By that I mean both the process (as shown by ps -A | grep trans), and the the torrenting is active (as shown by network monitor). I then watch the torrenting (uploading of linux torrents mostly) via web interface.

Build: 14307.

System: Linux Debian Jessie.

Example of processes
vlastimil@VB-NB-Debian:~$ ps -A | grep trans
8165 ? 00:00:41 transmission-qt
19419 ? 00:00:00 transmission-qt

You can see the two ones, what you don't see is that the latter doesn't really upload anything luckily. I then kill it with $ kill -9 19419.

I hope I described it alright.

Change History (3)

comment:1 Changed 7 years ago by mike.dld

  • Resolution set to invalid
  • Status changed from new to closed

Not sure what you want us to do. I'd think it's window manager's (or someone else's) responsibility to move windows to another screen when the one they are currently on disappears.

It is unclear from the description where does second process come from.

See also http://sourceforge.net/p/trqtw/bugs/62/ for similar discussion.

comment:2 Changed 7 years ago by burianvlastimil

Resolution is set to WQHD 2560x1440 + FullHD 1920x1080, why is that invalid?

https://en.wikipedia.org/wiki/Graphics_display_resolution#WQHD_.282560x1440.29

Where the second process comes from?: I simply run the application for the second time.

Why you should investigate? Because all other applications (or better said windows) are being moved ok.

comment:3 Changed 7 years ago by mike.dld

Display resolution has nothing to do with Trac ticket resolution ;)

The application should not care about moving its windows to one or another display, that's not its responsibility. See if "all other applications" are using different programming libraries (like, GTK+ instead of Qt, or Qt version X instead of Qt version Y), that's more likely to cause the difference in behavior.

Note: See TracTickets for help on using tickets.