Opened 7 years ago

Closed 7 years ago

#6022 closed Bug (fixed)

Crashes Within 15 Minutes in El Capitan

Reported by: catfish27 Owned by: mike.dld
Priority: Normal Milestone: 2.90
Component: Mac Client Version: 2.84
Severity: Normal Keywords: crash
Cc:

Description

Since installing El Capitan (release version), Transmission crashes for me after it's been running for 5 to 15 minutes. Doesn't seem to make any difference whether data is being transferred or not. Doesn't seem to have anything to do with the screensaver starting up, or anything else I can control -- I had no issues under Yosemite, and installing El Capitan has been the only change to my system.

I did try the troubleshooting steps given in this forum post, and it did work for me, but only until I restarted my computer. Following the restart, Transmission began displaying the same crashing behavior.

Crash report from 2.84 release version: http://pastebin.com/zE7eYU3G

Same behavior occurred with nightly version. Crash report: http://pastebin.com/Tq1y3QLj

Change History (13)

comment:1 Changed 7 years ago by x190

Please repeat these steps and install the latest nightly. Then load new torrent(s) to eliminate the possibility you were running a problematic torrent.

Also check your Message Log (command-3) in debug mode, while Transmission is running and look for related issues.

Check your Console.app for related entries as well.

Last edited 7 years ago by x190 (previous) (diff)

comment:2 follow-up: Changed 7 years ago by catfish27

Okay, I've done the steps, and am now running version 2.84+ (14600).

I'm slowly re-adding torrents (I have 5,661 to add) and will check the Message Log for anything odd.

As I said above, the last time I went through the steps, there were no crashes until after I restarted my computer.

comment:3 in reply to: ↑ 2 Changed 7 years ago by x190

Replying to catfish27:

As I said above, the last time I went through the steps, there were no crashes until after I restarted my computer.

Do you shut Transmission down normally, or do you force-quit it?

comment:4 Changed 7 years ago by catfish27

I shut it down normally (along with other apps) before restarting.

comment:5 follow-up: Changed 7 years ago by catfish27

So far so good, although I haven't had to restart my computer yet.

I do see in the Message Log the error "Tracker gave HTTP response code 414 (Request-URI Too Long)" appearing for a number of different torrents.

comment:6 in reply to: ↑ 5 Changed 7 years ago by x190

Replying to catfish27:

I do see in the Message Log the error "Tracker gave HTTP response code 414 (Request-URI Too Long)" appearing for a number of different torrents.

It would be wise to find out why. If this is a private tracker, ask them for details.

If possible, tag these torrents and remove them before trying to restart your computer.

Last edited 7 years ago by x190 (previous) (diff)

comment:7 follow-up: Changed 7 years ago by catfish27

There appears to have been a brief power outage that caused my computer to restart, and now it's back to the crashing behavior.

Crash log: http://pastebin.com/Uc1x6F1U

Looks like there hasn't been a new nightly build release, but I'll do the rest of the troubleshooting steps again -- this time I'll add a smaller number of torrents before forcing a restart, and see what happens with that.

comment:8 Changed 7 years ago by catfish27

Best I can tell, any given torrent will not consistently give that error -- it may give the error once, and then appears to announce fine the next time.

One more piece of info is that when hovering over those error messages in the log, I get the message "announcer.c:1279."

It is a private tracker -- I'll ask for details.

comment:9 in reply to: ↑ 7 Changed 7 years ago by x190

Replying to catfish27:

There appears to have been a brief power outage that caused my computer to restart, and now it's back to the crashing behavior.

Crash log: http://pastebin.com/Uc1x6F1U

You need to get an UPS unit to handle power surges and outages, otherwise you will get corrupted files, which can then cause a crash.

Do you have Transmission set to auto-remove torrents on 'seeding-complete'?

Version 0, edited 7 years ago by x190 (next)

comment:10 Changed 7 years ago by mike.dld

See if r14601+ nightly makes it better.

comment:11 Changed 7 years ago by catfish27

Running 14602, and the issue appears to have been fixed! No crashes, even after a restart.

The previously mentioned restart due to a power glitch appears to have actually been due to a kernel panic caused by another app. (Electric power here is generally very reliable.)

The answer I got about the 414-Request-URI Too Long error is that it appears to be normal -- the URI on a certain scrape request is longer than the tracker's allowed length, so it returns the error.

Thanks, everyone.

comment:12 Changed 7 years ago by mike.dld

  • Owner changed from livings124 to mike.dld
  • Status changed from new to assigned

comment:13 Changed 7 years ago by mike.dld

  • Milestone changed from None Set to 2.90
  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks, closing then.

Note: See TracTickets for help on using tickets.