Opened 6 years ago

Closed 6 years ago

#6039 closed Bug (fixed)

"Cannot lock focus" exception

Reported by: golergka Owned by: livings124
Priority: Normal Milestone: 2.90
Component: Mac Client Version: 2.84+
Severity: Normal Keywords:
Cc:

Description

xcode 7.2, OSX 10.10.5

Steps to reproduce:

  1. Checkout repo from SVN
  2. Open project in xcode
  3. select "My Mac (64-bit)" target.
  4. Build
  5. Run

Expected behaviour: Transmission launches

Actual behaviour:

On initialization, app crashes with following exception (includes one re-throw):

2015-12-22 01:18:48.527 Transmission[91627:2131643] An uncaught exception was raised
2015-12-22 01:18:48.527 Transmission[91627:2131643] Cannot lock focus on image <NSImage 0x60800026b580 Size={0, 0} Reps=(
)>, because it is size zero.
2015-12-22 01:18:48.528 Transmission[91627:2131643] (
	0   CoreFoundation                      0x00007fff8797f03c __exceptionPreprocess + 172
	1   libobjc.A.dylib                     0x00007fff8dd5776e objc_exception_throw + 43
	2   CoreFoundation                      0x00007fff8797eeed +[NSException raise:format:] + 205
	3   AppKit                              0x00007fff90d18c4e -[NSImage _lockFocusOnRepresentation:rect:context:hints:flipped:] + 334
	4   AppKit                              0x00007fff90d18aed __51-[NSImage lockFocusWithRect:context:hints:flipped:]_block_invoke + 82
	5   AppKit                              0x00007fff90d17dc6 -[NSImage _usingBestRepresentationForRect:context:hints:body:] + 164
	6   AppKit                              0x00007fff90d17d0b -[NSImage lockFocusWithRect:context:hints:flipped:] + 207
	7   AppKit                              0x00007fff90e24264 -[NSImage lockFocusFlipped:] + 123
	8   Transmission                        0x00000001000653f2 -[InfoTabButtonCell setSelectedTab:] + 418
	9   Transmission                        0x00000001000651a7 -[InfoTabButtonCell awakeFromNib] + 327
	10  CoreFoundation                      0x00007fff8788bbdf -[NSSet makeObjectsPerformSelector:] + 223
	11  AppKit                              0x00007fff90ca603d -[NSIBObjectData nibInstantiateWithOwner:options:topLevelObjects:] + 1216
	12  AppKit                              0x00007fff90c850e5 loadNib + 384
	13  AppKit                              0x00007fff90c8460b +[NSBundle(NSNibLoading) _loadNibFile:nameTable:options:withZone:ownerBundle:] + 313
	14  AppKit                              0x00007fff90e33bf7 +[NSBundle(NSNibLoadingInternal) _loadNibFile:externalNameTable:options:withZone:] + 150
	15  AppKit                              0x00007fff90e3399d -[NSWindowController loadWindow] + 313
	16  AppKit                              0x00007fff90e2eb65 -[NSWindowController window] + 80
	17  Transmission                        0x0000000100024cef -[Controller validateToolbarItem:] + 2495
	18  Transmission                        0x0000000100069061 -[ButtonToolbarItem validate] + 81
	19  AppKit                              0x00007fff90d3eb8f -[NSToolbarItemViewer configureForLayoutInDisplayMode:andSizeMode:inToolbarView:] + 860
	20  AppKit                              0x00007fff90d3cbd9 -[NSToolbarView _layoutDirtyItemViewersAndTileToolbar] + 1258
	21  AppKit                              0x00007fff90d383c1 -[NSToolbarView _syncItemSetAndUpdateItemViewersWithSEL:setNeedsModeConfiguration:sizeToFit:setNeedsDisplay:updateKeyLoop:] + 166
	22  AppKit                              0x00007fff90d38310 -[NSToolbarView _noteToolbarLayoutChanged] + 47
	23  AppKit                              0x00007fff90cadc05 -[NSView _setWindow:] + 3368
	24  AppKit                              0x00007fff90cb8d93 -[NSView addSubview:] + 463
	25  AppKit                              0x00007fff90cc63b7 -[NSThemeFrame addTitlebarSubview:] + 105
	26  AppKit                              0x00007fff90d37e4a -[NSThemeFrame _showHideToolbar:resizeWindow:animate:] + 71
	27  AppKit                              0x00007fff90d2416c -[NSWindow _showToolbar:animate:] + 160
	28  AppKit                              0x00007fff90d240b4 -[NSToolbar _show:animate:] + 52
	29  AppKit                              0x00007fff90d2319e -[NSWindow setToolbar:] + 612
	30  Transmission                        0x0000000100004aaf -[Controller awakeFromNib] + 271
	31  CoreFoundation                      0x00007fff8788bbdf -[NSSet makeObjectsPerformSelector:] + 223
	32  AppKit                              0x00007fff90ca603d -[NSIBObjectData nibInstantiateWithOwner:options:topLevelObjects:] + 1216
	33  AppKit                              0x00007fff90c850e5 loadNib + 384
	34  AppKit                              0x00007fff90c8460b +[NSBundle(NSNibLoading) _loadNibFile:nameTable:options:withZone:ownerBundle:] + 313
	35  AppKit                              0x00007fff90c843c7 -[NSBundle(NSNibLoading) loadNibNamed:owner:topLevelObjects:] + 201
	36  AppKit                              0x00007fff90c84193 +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 344
	37  AppKit                              0x00007fff90c7cd79 NSApplicationMain + 605
	38  Transmission                        0x000000010000232b main + 155
	39  Transmission                        0x0000000100001b74 start + 52
)
2015-12-22 01:18:48.708 Transmission[91627:2131643] *** Terminating app due to uncaught exception 'NSImageCacheException', reason: 'Cannot lock focus on image <NSImage 0x60800026b580 Size={0, 0} Reps=(
)>, because it is size zero.'
*** First throw call stack:
(
	0   CoreFoundation                      0x00007fff8797f03c __exceptionPreprocess + 172
	1   libobjc.A.dylib                     0x00007fff8dd5776e objc_exception_throw + 43
	2   CoreFoundation                      0x00007fff8797eeed +[NSException raise:format:] + 205
	3   AppKit                              0x00007fff90d18c4e -[NSImage _lockFocusOnRepresentation:rect:context:hints:flipped:] + 334
	4   AppKit                              0x00007fff90d18aed __51-[NSImage lockFocusWithRect:context:hints:flipped:]_block_invoke + 82
	5   AppKit                              0x00007fff90d17dc6 -[NSImage _usingBestRepresentationForRect:context:hints:body:] + 164
	6   AppKit                              0x00007fff90d17d0b -[NSImage lockFocusWithRect:context:hints:flipped:] + 207
	7   AppKit                              0x00007fff90e24264 -[NSImage lockFocusFlipped:] + 123
	8   Transmission                        0x00000001000653f2 -[InfoTabButtonCell setSelectedTab:] + 418
	9   Transmission                        0x00000001000651a7 -[InfoTabButtonCell awakeFromNib] + 327
	10  CoreFoundation                      0x00007fff8788bbdf -[NSSet makeObjectsPerformSelector:] + 223
	11  AppKit                              0x00007fff90ca603d -[NSIBObjectData nibInstantiateWithOwner:options:topLevelObjects:] + 1216
	12  AppKit                              0x00007fff90c850e5 loadNib + 384
	13  AppKit                              0x00007fff90c8460b +[NSBundle(NSNibLoading) _loadNibFile:nameTable:options:withZone:ownerBundle:] + 313
	14  AppKit                              0x00007fff90e33bf7 +[NSBundle(NSNibLoadingInternal) _loadNibFile:externalNameTable:options:withZone:] + 150
	15  AppKit                              0x00007fff90e3399d -[NSWindowController loadWindow] + 313
	16  AppKit                              0x00007fff90e2eb65 -[NSWindowController window] + 80
	17  Transmission                        0x0000000100024cef -[Controller validateToolbarItem:] + 2495
	18  Transmission                        0x0000000100069061 -[ButtonToolbarItem validate] + 81
	19  AppKit                              0x00007fff90d3eb8f -[NSToolbarItemViewer configureForLayoutInDisplayMode:andSizeMode:inToolbarView:] + 860
	20  AppKit                              0x00007fff90d3cbd9 -[NSToolbarView _layoutDirtyItemViewersAndTileToolbar] + 1258
	21  AppKit                              0x00007fff90d383c1 -[NSToolbarView _syncItemSetAndUpdateItemViewersWithSEL:setNeedsModeConfiguration:sizeToFit:setNeedsDisplay:updateKeyLoop:] + 166
	22  AppKit                              0x00007fff90d38310 -[NSToolbarView _noteToolbarLayoutChanged] + 47
	23  AppKit                              0x00007fff90cadc05 -[NSView _setWindow:] + 3368
	24  AppKit                              0x00007fff90cb8d93 -[NSView addSubview:] + 463
	25  AppKit                              0x00007fff90cc63b7 -[NSThemeFrame addTitlebarSubview:] + 105
	26  AppKit                              0x00007fff90d37e4a -[NSThemeFrame _showHideToolbar:resizeWindow:animate:] + 71
	27  AppKit                              0x00007fff90d2416c -[NSWindow _showToolbar:animate:] + 160
	28  AppKit                              0x00007fff90d240b4 -[NSToolbar _show:animate:] + 52
	29  AppKit                              0x00007fff90d2319e -[NSWindow setToolbar:] + 612
	30  Transmission                        0x0000000100004aaf -[Controller awakeFromNib] + 271
	31  CoreFoundation                      0x00007fff8788bbdf -[NSSet makeObjectsPerformSelector:] + 223
	32  AppKit                              0x00007fff90ca603d -[NSIBObjectData nibInstantiateWithOwner:options:topLevelObjects:] + 1216
	33  AppKit                              0x00007fff90c850e5 loadNib + 384
	34  AppKit                              0x00007fff90c8460b +[NSBundle(NSNibLoading) _loadNibFile:nameTable:options:withZone:ownerBundle:] + 313
	35  AppKit                              0x00007fff90c843c7 -[NSBundle(NSNibLoading) loadNibNamed:owner:topLevelObjects:] + 201
	36  AppKit                              0x00007fff90c84193 +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 344
	37  AppKit                              0x00007fff90c7cd79 NSApplicationMain + 605
	38  Transmission                        0x000000010000232b main + 155
	39  Transmission                        0x0000000100001b74 start + 52
)
libc++abi.dylib: terminating with uncaught exception of type NSException

Issue was introduced in r14626. SVN revisino r14625 builds and runs without a problem.

Change History (1)

comment:1 Changed 6 years ago by mike.dld

  • Milestone changed from None Set to 2.90
  • Resolution set to fixed
  • Status changed from new to closed

Fixed by r14631, thanks.

Note: See TracTickets for help on using tickets.