Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6045 closed Bug (worksforme)

Icon in the notification area: right and left click behavior should be different

Reported by: morph Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.84
Severity: Normal Keywords:
Cc:

Description

Hello, this has been reported in Debian as http://bugs.debian.org/801299

It seems that on recent Desktop environments, like XFCE and GNOME, the right and left click generate the same menu, while on previous version, left click opened Transmission windows and right click opened the menu

Change History (9)

comment:1 Changed 6 years ago by mike.dld

  • Resolution set to worksforme
  • Status changed from new to closed

Works fine here. Any more details?..

comment:2 Changed 6 years ago by morph

not really, how can I provide more details?

comment:3 Changed 6 years ago by mike.dld

Well, it would help if more than a single user was able to reproduce this. It would also be nice to know exactly whether it's Xcfe (which is mentioned in Debian ticket) or GNOME (which isn't) or indeed both, and versions of those where issue has been noticed. Does using transmission-qt instead of transmission-gtk change anything? Does upgrading or downgrading packages help?

For the reference, I have GTK+ 3.18.5 and xfce4-panel 4.12, both transmission-gtk and transmission-qt function as expected.

comment:4 Changed 6 years ago by morph

The reporter of the debian bug uses XFCE, I am using GNOME 3.18.2 (classic mode) and I can replicate this in GNOME, but only with transmission-gtk, I just tried with transmission-qt in GNOME and it works as expected.

Here are the dependencies of transmission-gtk on my system:

ii  libappindicator3-1   0.4.92-3.1
ii  libc6                2.19-22
ii  libcurl3-gnutls      7.45.0-1+b1
ii  libevent-2.0-5       2.0.21-stable-2+b1
ii  libgdk-pixbuf2.0-0   2.32.2-1
ii  libglib2.0-0         2.46.2-1
ii  libgtk-3-0           3.18.5-1
ii  libminiupnpc10       1.9.20140610-2.1
ii  libnatpmp1           20110808-3
ii  libpango-1.0-0       1.38.1-1
ii  libssl1.0.2          1.0.2d-3
ii  transmission-common  2.84-2
ii  zlib1g               1:1.2.8.dfsg-2+b1

comment:5 Changed 6 years ago by mike.dld

The difference could be that you both use libappindicator and I don't. Qt client is probably not using libappindicator either.

comment:6 Changed 6 years ago by mike.dld

Not sure what was the documentation before, but from what I could find now the function app_indicator_set_menu() is said to set "the menu that should be shown when the Application Indicator is clicked on in the panel", with no differentiation between left and right click. Looks like this is no news (see e.g. http://ubuntuforums.org/archive/index.php/t-1510241.html from 2010). Could it be that transmission-gtk package was not using libappindicator in previously released versions?

comment:7 Changed 6 years ago by morph

Indeed Mike the addition of libappindicator is only since April '15 and not in the previous release of transmission in Debian; also only -gtk is using appindicator:

$ ldd /usr/bin/transmission-gtk | grep indi
        libappindicator3.so.1 => /usr/lib/libappindicator3.so.1 (0x00007fc569f67000)
        libindicator3.so.7 => /usr/lib/libindicator3.so.7 (0x00007fc567009000)
$ ldd /usr/bin/transmission-qt | grep indi

I dont know exactly the advantage/disadvantage of using libappindicator, or if the behaviour of just presenting the menu no matter if it's a right or left click is a bug or a feature - what would you suggest to do?

comment:8 Changed 6 years ago by mike.dld

I guess it's up to you then to decide what to do :) If libappindicator behaves this way for a long time, this seems to suit those who use it (I'd say Ubuntu, right?). If this is not what Debian users prefer and/or are used to, you could build the GTK+ client without libappindicator. Granted, there doesn't seem to be a simple option to disable its use, we could help you with that.

Last edited 6 years ago by mike.dld (previous) (diff)

comment:9 Changed 6 years ago by morph

hehe yup makes sense, I will just remove libappindicator from the build environment, that should revert teh situation to what it was before (and consistent with -qt) - thanks a ton for your help!

Note: See TracTickets for help on using tickets.