Opened 6 years ago

Closed 6 years ago

#6047 closed Bug (invalid)

filter combobox has wrong count

Reported by: morph Owned by: jordan
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 2.84
Severity: Normal Keywords:
Cc:

Description

Hello, I have this behaviour (see attachment) where the first combobox has the wrong count (it seems to lack the last digit), but if I click on it to change the filtering, the numbers there are correct. it is not only related to the 'Active' filter, even the others (at lease 'Paused') is affected

Attachments (2)

Screenshot from 2016-01-02 18-05-00.png (3.0 KB) - added by morph 6 years ago.
combo-test.glade (1.4 KB) - added by mike.dld 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by morph

comment:1 Changed 6 years ago by mike.dld

  • Component changed from Transmission to GTK+ Client
  • Owner set to jordan

comment:2 Changed 6 years ago by mike.dld

  • Resolution set to invalid
  • Status changed from new to closed

Looks like a GTK+ issue. Using Glade 3.18.3 and GTK+ 3.18.6, tried recreating the interface with a combobox with two columns and two rows:

| Downloading | 69   |
| Seeding     | 6699 |

And then testing it with "Preview shapshot" action. Popup menu displays fine. After selecting first item, combobox displays fine, after selecting second item, "6699" is clipped by half. Seems to be somehow connected to text lengths in different model cells. Changing "Seeding" to "SeedingWWWW" (i.e. making its width equal to or longer than that of "Downloading") results in "6699" being displayed in full.

Changed 6 years ago by mike.dld

Note: See TracTickets for help on using tickets.