Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#6083 closed Bug (fixed)

Seeding Complete notices are unable to be removed on OS X

Reported by: welles Owned by: mike.dld
Priority: Normal Milestone: 2.91
Component: Mac Client Version: 2.90
Severity: Normal Keywords:
Cc:

Description

On OS X 10.11.3 the Seeding Complete notifications for Notification Center are unable to be removed. Clicking the "X" does not remove them.

Change History (9)

comment:1 Changed 2 years ago by welles

If you change the "Notification Center sort order" from "Recents" to "Recents by App", the notifications are then able to be cleared.

comment:2 Changed 2 years ago by mike.dld

  • Resolution set to invalid
  • Status changed from new to closed

Transmission has no direct influence on what Notification Center does, it uses Growl for notifications.

comment:3 Changed 2 years ago by welles

OK. So is it a Growl or Notification Center issue? As the only way to clear the notices was to change the sort order in Notification Center.

comment:4 Changed 2 years ago by mike.dld

I wouldn't know, but it sounds like an Apple (Notification Center) issue.

comment:5 Changed 2 years ago by mike.dld

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:6 Changed 2 years ago by mike.dld

  • Milestone changed from None Set to 2.91
  • Owner changed from livings124 to mike.dld
  • Status changed from reopened to new

I cannot explain this, but it seems like Transmission is indeed to blame here (well, kind of, I still think the root cause somewhere else).

And also, I was wrong and Transmission is indeed using notification center API on 10.8+.

comment:7 Changed 2 years ago by livings124

I've seen this as well. Maybe it's Growl and Notification Center interacting?

comment:8 Changed 2 years ago by livings124

  • Resolution set to fixed
  • Status changed from new to closed

comment:9 Changed 2 years ago by x190

Fixed in #14703.

Last edited 2 years ago by x190 (previous) (diff)
Note: See TracTickets for help on using tickets.