Opened 2 years ago

Closed 2 years ago

#6090 closed Enhancement (duplicate)

Add option to download a torrent as a stream

Reported by: rodrigocc Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.84
Severity: Normal Keywords:



There are several way to download a torrent as a stream, so you can watch it while it downloads. For example, here:,, etc.

They usually have an HTTP server so if the download is slow, or you want to see after the first 30 min, they also adjust for that (i.e. wait for the buffer to fill, or start downloading other pieces of the torrent).

I'd like if transmission can download a torrent as a stream, so that iif the download is fast enough, you can see it while it's downloading. The HTTP server and all the other features are not needed, IMHO.

I'd love if transmission can do that, because that way I can probably see most of the torrents I download (without all the features having an HTTP server has, but I don't care) and also continue to seed them after I watched, with the policy I have for all the torrents and BW limitations.

I might also write an HTTP server that just waits for the buffer to fill, if it drains, and just use it with transmission to see what I download.

Thanks a lot,


Change History (2)

comment:1 Changed 2 years ago by JJTagy

Duplicate of #452

comment:2 Changed 2 years ago by mike.dld

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.