Opened 13 years ago

Closed 10 years ago

#617 closed Bug (fixed)

Transmission goes above the set bandwidth limits

Reported by: persept Owned by: charles
Priority: High Milestone: 1.40
Component: libtransmission Version: 1.11
Severity: Major Keywords:
Cc:

Description

When I set transmission to only upload at 40KB/s, it continually goes up and down in upload speed, changing from 5KB/s even up to bursts of 100KB/s. Even though if this were averaged it would equal 40KB/s, these bandwidth spikes are much higher than my internet service allows (45KB/s). This causes ping times to increase over 10x and internet speeds to greatly suffer on all machines on my network. This seems to be a problem with transmission because if I use the throttled daemon to throttle my upload speed to 40KB/s, it uploads consistently at 40KB/s, almost never dropping down in upload speed (as long as I'm seeding enough torrents)

Attachments (3)

uploadrate.png (163.5 KB) - added by bmauter 13 years ago.
Transmission Bug.jpg (59.4 KB) - added by dalr 13 years ago.
Transmission goes berserk
transmission-bw-bug.jpg (119.6 KB) - added by Revolt 10 years ago.
Transmission-gtk Bandwidth bug, Gnome 2.32, Arch Linux

Download all attachments as: .zip

Change History (37)

comment:1 Changed 13 years ago by charles

I'm not seeing any behavior like this at all... is the main window saying you'r uploading 100KB/s??

comment:2 Changed 13 years ago by charles

  • Status changed from new to assigned
  • Version changed from 1.00+ to 1.01

comment:3 Changed 13 years ago by livings124

  • Resolution set to worksforme
  • Status changed from assigned to closed

No one else has reported this, and I can't say I have seen speeds go so high over the limit.

comment:4 Changed 13 years ago by persept

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 1.01 to 1.06

@charles Transmission reports an upload speed of 40KB/s, which is what I set the maximum upload speed to. Using an external program, I can see the instantaneous upload speed, which I can see go down and up. It can have an instantaneous speed of up to 100KB/s, down to 0KB/s. Transmission reports 40KB/s which is probably accurate if you were to average the spikes with the valley's. The problem is that Transmission doesn't maintain a constant stream of 40KB/s. Though it is possible to acheive a constant stream of 40KB/s by using a daemon called 'throttled'. Which throttles the maximum upload of my computer to 40KB/s. Maybe something in the upload limiter can be used to make transmission have a more smooth upload rate?

comment:5 Changed 13 years ago by persept

  • Cc persept@… added

comment:6 Changed 13 years ago by persept

  • Version changed from 1.06 to 1.11

Here's a video I made of the problem. I used Transmission version 1.11 set to a maximum of 10KB/s upload speed and an unlimited download speed running two torrents. The other application in the video is OS X's Activity monitor program. As this video shows, the upload speed greatly exceeds my set limit, many times going more than two times over the set limit.

comment:7 Changed 13 years ago by persept

sorry but the 488KB file was too big to upload directly to trac. here's an external link http://www.mediafire.com/?1xysehwbd1b

comment:8 Changed 13 years ago by persept

  • Cc persept@… removed

comment:9 Changed 13 years ago by dargol

Hi, I have witness this behaviour to. Here is a video I made to try and confirm this bug.

http://video.google.com/videoplay?docid=-360708926276078869

Using Debian's transmission 1.11 -5509- It was only seeding one torrent.

comment:10 Changed 13 years ago by tgos

I have exactly this issue, too.

See here: Ticket #919

I was using Bits on Wheels before and when I there set the upload limit to 40 KB/s, no matter how many uploading or downloading torrents I had at the same time, MenuMeters? always showed about 40 KB/s upload throughput.

With Transmission, if I only seed, it's between 40 and 55 KB/s (which is already over the limit, but not so dramatically). If I download as well at the same time, my overall traffic goes up to 80 and even 100 KB/s every couple of seconds.

Not sure what it does not take into account that other clients do, as it claims it is just using 40 KB/s, but a decent bandwidth limiting feature would take all protocol overhead into account, too, as well as all overhead caused by a download (a download causes upload overhead, too, as packages need to be requested and confirmed and tracker stats need to be updated... however all this should count as upload data and needs to be taken into account when throtteling the upload).

As I need to share my Internet connection with 4 other people, I need to be sure that I'm not sucking up all available bandwidth for myself and thus I need a client that really enforces my set up and download limits.

comment:11 Changed 13 years ago by dargol

charles is there anything I can do/test to help squash this one? some torrents choke because of it because upload conection is full.

Changed 13 years ago by bmauter

comment:12 Changed 13 years ago by bmauter

I have the same problem on Transmission 1.32 (6453). Please see attached screenshot.

comment:13 Changed 13 years ago by GanetMarV

  • Version changed from 1.11 to 1.33

When Transmission starts it complies with the upload limit. If I set to unlimited, wait a moment and set back to the previous limit. It's not limited anymore. It's like the last action to set the limit was ignored.

comment:14 Changed 13 years ago by livings124

  • Version changed from 1.33 to 1.11

comment:15 follow-up: Changed 13 years ago by rb07

Same problem with version 1.33, looking at the web interface transmission goes above on downloads and uploads.

Since there are many reports about this I don't see any point on adding proof or giving statistics, the problem is easy to observe and duplicate.

I don't see a difference 'when Transmission starts', it breaks the limits always, just not all the time.

comment:16 in reply to: ↑ 15 Changed 13 years ago by rb07

Replying to rb07: [snip]

I don't see a difference 'when Transmission starts', it breaks the limits always, just not all the time.

With only one active torrent, it keeps at or under the limit. The problem was observed, as I said always, when 2 or more torrents were active.

comment:17 follow-up: Changed 13 years ago by winterk

I've personally just encountered this issue starting with version 1.32. Transmission used to work fine until that release.

Since then, I seem to be experiencing all the symptoms described in the comments above me. (Reported bandwidth being far higher then available on my ISP package, symptoms manifesting when uploading more then one torrent at once, reported speed ignoring Bandwidth Limits.)

comment:18 in reply to: ↑ 17 Changed 13 years ago by drsassafras

  • Version changed from 1.11 to 1.33

I have also only encountered this problem in version 1.3.3. (but I don't think I installed 1.3.2. The behaviour on my machine is slightly different. I have a VoIP Phone and limit the upload to 10 during the day time. there is no observable low spikes on mine, and it can shoot all the way up to 200+ upload speed. Enough to sometimes take out my gutless VoIP Gateway. The upload does not average my specified max upload, it is much higher.

It seems as though this might be a slightly different bug than the initial report, as it appeared at a different time and displays slightly differently. Or maybe its the same bug and there was modified code that changed its characteristics in 1.3.2-1.3.3?

Replying to winterk:

I've personally just encountered this issue starting with version 1.32. Transmission used to work fine until that release.

comment:19 Changed 13 years ago by livings124

  • Version changed from 1.33 to 1.11

Version is set so that we know where it might have broke.

comment:20 Changed 13 years ago by dalr

I have the exact same problem. But it goes WELL above specified limits. With a 10KB/s limit, it's not unrare for Transmission to go WELL beyond 140KB/s, leaving my internet connection unusable, to say the least. And not just for a spike moment, but for hours.

Changed 13 years ago by dalr

Transmission goes berserk

comment:21 Changed 13 years ago by dalr

  • Priority changed from Normal to High
  • Severity changed from Normal to Major

Raising the severity because this clearly is of major problem to some users, and priority to high because it seems to have been open for a very long time. Hopefully a fix for the next release?

comment:22 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.40

the first draft of the speed limiting rewrite is in r6782

comment:23 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

It seems to be working now, but this is probably the kind of thing that will benefit from wider user testing. feel free to reopen this ticket as needed.

comment:24 Changed 10 years ago by anomaly256

  • Resolution fixed deleted
  • Status changed from closed to reopened

Unfortunately I'm seeing this problem now on 2.21 compiled form source on opensolaris.

If I start a fresh instance of transmission-daemon all speed limits are obeyed as expected. I walk away for some time, come back home and suddenly my entire outbound is getting entirely killed despite having told transmission-daemon to cap it at 50k/s. transmission-daemon now reports between 120k/s and 200k/s being used. I hit the 'slow' button, nothing changes at all in the daemon's bandwidth usage. Only way to get it back to a civil speed is to slay it and relaunch...

I wouldn't mind so much except my adsl modem is really crappy and when something is using all the outbound *everything* else just dies. ssh sessions stop responding, web browsing doesn't work, everything. It's quite frustrating :/

comment:25 Changed 10 years ago by livings124

#4021 is a duplicate of this.

Last edited 10 years ago by livings124 (previous) (diff)

comment:26 Changed 10 years ago by drsassafras

It appears to be working fine for me. No new problems introduced. OSX. I will keep an eye on it though and report if I find differently.

comment:27 Changed 10 years ago by Revolt

Have noticed this problem occasionally since the last update. Limited my upload speed to 300KB/sec since I have a 3mbps upload connection. Just now a torrent is averaging 500KB/sec upload (while gnome system monitor is reporting a total of 300-350KB/sec global upload).

Maybe it is a problem with the upload speed calculations rather than a bandwidth limiting problem?

Arch Linux x86_64 Gnome 2.32 Transmission-gtk 2.21 (latest from arch repository).

Changed 10 years ago by Revolt

Transmission-gtk Bandwidth bug, Gnome 2.32, Arch Linux

comment:28 Changed 10 years ago by rg

Since imho (!) https://trac.transmissionbt.com/changeset/12063 bandwidth limit is stuck

comment:29 Changed 10 years ago by jordan

Revolt, what version of Transmission are you using in that screenshot?

rg, could you give more details about what you mean?

Last edited 10 years ago by jordan (previous) (diff)

comment:30 Changed 10 years ago by Revolt

As I said on the post before the screenshot, that pertains to Transmission-gtk 2.21

comment:31 Changed 10 years ago by rg

I am on Ubuntu natty x86_64 behind a fli4l router. I can monitor the systemwide in-out network usage on the router. I wrote me a script to build (and update) Transmission and some dependencies (like libevent) that monitors and detects every update committed. As soon as a concerned file got updated, it pops me up the information and I can stop Transmision (and pgl on my router) and rebuild everything new with only one confirmation.

Exactly since the Update to Changeset 12064 at 03/02/11 morning the upload bandwidth limitation (I usually use 60 KiB/s) does not work any more. Neither the Transmission wide (like on Revolts screen shot) nor the per torrent speed limitation nor the so called "Alternative Speed Limit" are functioning here since that (yesterday) morning.

Do you need more details?

comment:32 Changed 10 years ago by rg

OK Jordan, now I did the test and checked out revision 12062, and yes, everything is working, changing to the revision 12063, bandwidth speed limitation speed limitation is stuck.

This is what I did:

svn co -r 12062 svn://svn.transmissionbt.com/Transmission/trunk TMr12062 cd TMr12062 ./autogen.sh && make -s sudo make install

Regards

comment:33 Changed 10 years ago by rg

Confirmation: Changeset 12072 fixed this, speed-limitation is working again. Thank you very much for your work on this gorgeous project!

comment:34 Changed 10 years ago by jordan

  • Resolution set to fixed
  • Status changed from reopened to closed

Re-closing based on feedback from rg

Note: See TracTickets for help on using tickets.