Opened 13 years ago

Closed 13 years ago

#622 closed Bug (invalid)

preferences window always opens in virtual desktop 1 on leopard

Reported by: aaron Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.04
Severity: Normal Keywords:
Cc:

Description

On leopard, if you move transmission to another virtual desktop, then open the preferences, the window opens in virtual desktop 1. The preferences should open in the same virtual desktop as transmission.

Change History (12)

comment:1 Changed 13 years ago by charles

  • Component changed from Transmission to OS X Interface
  • Owner set to livings124

comment:2 follow-up: Changed 13 years ago by John Clay

  • Resolution set to worksforme
  • Status changed from new to closed

Works for me on rev 4893, 10.5.1.

comment:3 in reply to: ↑ 2 Changed 13 years ago by John Clay

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to John Clay:

Works for me on rev 4893, 10.5.1.

Hmm. Just tested it a bit more, and it seems that the first time you open prefs, it will open in that Space always. Doesn't matter if it's space 2, 3, 15 etc. Works fine when quit, relaunched in single space.

comment:4 Changed 13 years ago by John Clay

  • Milestone changed from None Set to Sometime
  • Priority changed from Normal to High
  • Version changed from 1.01 to 1.04+

comment:5 Changed 13 years ago by livings124

  • Milestone changed from Sometime to None Set
  • Priority changed from High to Normal

comment:6 Changed 13 years ago by charles

  • Version changed from 1.04+ to 1.04

comment:7 Changed 13 years ago by jidanni

By the way, when clicking "Preferences" after installing 1.10 on Linux, see the error

The folder contents could not be displayed Error getting information for '/home/jidanni/Desktop': No such file or directory

Ha, it thinks everybody has such a silly directory in their $HOME.

P.S., No tooltip or documentation available for "Forward port from router" or many other preferences.

comment:8 Changed 13 years ago by livings124

jidanni: That is completely unrelated to this ticket. This ticket discusses the Spaces feature on Mac.

comment:9 Changed 13 years ago by charles

Is this still the case 1.21?

comment:10 Changed 13 years ago by livings124

Yes.

comment:11 Changed 13 years ago by livings124

The problem is there's no API from Apple to set the specific space. My only other option is to release the window and regenerate it on next reopen. I do this on windows like the Groups window, but it's not as practical to do this on windows like Prefs, since the window is tied to a lot of the preference-setting code.

comment:12 Changed 13 years ago by livings124

  • Resolution set to invalid
  • Status changed from reopened to closed

It appears iChat and Safari behave the same way as Transmission. Until Apple opens up the API for Spaces, there's nothing I can do.

Note: See TracTickets for help on using tickets.