Opened 14 years ago

Closed 14 years ago

#666 closed Bug (fixed)

pausing in the middle of "verify local data" makes T forget about the nonverified portion

Reported by: charles Owned by: charles
Priority: Normal Milestone: 1.04
Component: libtransmission Version: 1.02
Severity: Major Keywords:
Cc:

Description

This was reported earlier today in a macrumors forum post by TheStu?:

"My only issue with Transmission is that time once in a blue moon when it has to verify data. If you pause all before the verify is done (I have done it twice in the past 2 weeks, kicked myself both times) it 'forgets' what it was downloaded thus far, and unless parts of it are completely done (and that doesn't even work sometimes) it restarts the whole thing. I have had to restart the same 6GB torrent twice now because of that issue."

Change History (4)

comment:1 Changed 14 years ago by eisa01

I don't know if this is related, but it's two other bugs in the Verify Local Data function.

Have a torrent that you seed. Choose verify local data. Pause it. Resume it. --> Expected behaviour here would be to resume checking the data. The download starts again from the point you paused the verifying. Choose verify local data. --> Expected behaviour would be to pause the download The torrent will now check the data, and download to the file at the same time.

I have done this two times, and has both times lead to the file ending up complete in the end, so no data loss.

comment:2 Changed 14 years ago by charles

  • Milestone changed from None Set to 1.10
  • Severity changed from Normal to Major
  • Status changed from new to assigned

comment:3 Changed 14 years ago by charles

eisa01: yes, I think you're describing the same bug.

This needs to be fixed RSN, but in the meantime a very simple workaround exists: press `verify local data' again.

comment:4 Changed 14 years ago by charles

  • Milestone changed from 1.10 to 1.04
  • Resolution set to fixed
  • Status changed from assigned to closed

trunk: r4884 1.0x: r4885

Note: See TracTickets for help on using tickets.