Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#674 closed Bug (fixed)

console warning messages when preferences dialog is open during shutdown

Reported by: crf Owned by: charles
Priority: Normal Milestone: 1.05
Component: GTK+ Client Version: 1.04
Severity: Minor Keywords:
Cc:

Description

Start transmission gtk from the command line, open the preferences window and then quit. Some warnings appear on the command line. I'm using version 1.04+ rev 4895 -->

(transmission:16740): GLib-GObject-WARNING : invalid uninstantiatable type void' in cast to GtkFileSystemHandle?'

(transmission:16740): GLib-GObject-WARNING : invalid uninstantiatable type (null)' in cast to GtkFileSystemHandle?'

(transmission:16740): GLib-GObject-WARNING : invalid uninstantiatable type (null)' in cast to GtkFileSystemHandle?'

(transmission:16740): Gtk-CRITICAL : gtk_file_system_cancel_operation: assertion `GTK_IS_FILE_SYSTEM_HANDLE (handle)' failed

(transmission:16740): Gtk-CRITICAL : gtk_file_system_cancel_operation: assertion `GTK_IS_FILE_SYSTEM_HANDLE (handle)' failed

(transmission:16740): Gtk-CRITICAL : gtk_file_system_cancel_operation: assertion `GTK_IS_FILE_SYSTEM_HANDLE (handle)' failed

Change History (4)

comment:1 Changed 14 years ago by charles

  • Milestone changed from None Set to 1.10
  • Status changed from new to assigned
  • Version changed from 1.04+ to 1.04

comment:2 Changed 14 years ago by charles

  • Milestone changed from 1.10 to None Set

crf: I can't reproduce this. Is this a consistent behavior for you, and which version of gtk+ are you using?

comment:3 Changed 14 years ago by charles

  • Milestone changed from None Set to 1.05
  • Resolution set to fixed
  • Status changed from assigned to closed

1.0x: r4944 trunk: r4945

I thinks this fixes it. Please reopen if I'm wrong... even before the chance I only saw the warnings once in a blue moon.

comment:4 Changed 14 years ago by charles

  • Summary changed from Warnings appear on the command line when gtk-transmission is quit with preferences window open to console warning messages when preferences dialog is open during shutdown
Note: See TracTickets for help on using tickets.