Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#678 closed Bug (duplicate)

Crash-on-launch in r4885

Reported by: devin.chalmers@… Owned by:
Priority: Normal Milestone: 1.05
Component: libtransmission Version: 1.04
Severity: Normal Keywords:
Cc:

Description

After upgrading to r4885 with the automatic updater, Transmission crashes on launch (Leopard 10.5.1, PowerMac? G4 dual 867). Approx. 10 seconds after launch,

2/2/08 11:49:21 AM [0x0-0x668668].org.m0k.transmission[21351] /Users/mitchell/Desktop/Transmission_1.0x/libtransmission/bencode.c:538: failed assertion `node->childCount == n'

is logged to the Console (Mitchell?). One CPU gets pegged for about 10-20 seconds, and then

2/2/08 11:49:34 AM com.apple.launchd[85] ([0x0-0x668668].org.m0k.transmission[21351]) Exited abnormally: Abort trap

Bummer, dude. Total bummer.

Full crash log attached.

Attachments (1)

Transmission_2008-02-02-114921_Servertron.crash (20.5 KB) - added by devin.chalmers@… 13 years ago.
Crash log

Download all attachments as: .zip

Change History (9)

Changed 13 years ago by devin.chalmers@…

Crash log

comment:1 Changed 13 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

This is already fixed.

comment:2 follow-up: Changed 13 years ago by devin.chalmers@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

The current revision on the website still crashes on launch. I don't know how you manage your bugtracker, but where I work we don't close tickets until the fix is deployed...

comment:3 Changed 13 years ago by livings124

  • Resolution set to invalid
  • Status changed from reopened to closed

How can we manage bugs if we don't know what's fixed before release?

comment:4 in reply to: ↑ 2 Changed 13 years ago by John Clay

Replying to devin.chalmers@gmail.com:

The current revision on the website still crashes on launch. I don't know how you manage your bugtracker, but where I work we don't close tickets until the fix is deployed...

Might I point out that you don't work here, and we close bugs when they're fixed, not deployed. Don't mess with the system.

comment:5 Changed 13 years ago by devin.chalmers@…

Sorry, didn't realize your tracker doesn't distinguish between resolved and closed bugs. Carry on with your business.

comment:6 Changed 13 years ago by charles

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:7 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.05
  • Resolution set to duplicate
  • Status changed from reopened to closed

This is a duplicate of ticket #676, which is fixed in svn and slated for 1.05

comment:8 Changed 13 years ago by charles

  • Component changed from Transmission to libtransmission
Note: See TracTickets for help on using tickets.