Opened 14 years ago

Closed 14 years ago

Last modified 10 years ago

#714 closed Bug (fixed)

makemeta breaks on non-absolute pathnames

Reported by: follicycle Owned by: charles
Priority: Normal Milestone: 1.06
Component: libtransmission Version: 1.05
Severity: Normal Keywords:
Cc:

Description

Creating a torrent on Ubuntu 7.10 gutsy server with transmissioncli 1.04, 1.05 and current SVN tree results in a .torrent that will not seed.

Loading the .torrent file into another torrent client, the filenames shown are of the format:

t/01 Filename.file
t/02 Filename.file
t/03 Filename.file

and so on. Where t is the last character of the directory that was used to create the torrent.

example command line usage:

transmissioncli -c "This is my new torrent" -a http://tracker.bt/announce -r test.torrent

Same behavior with and without spaces in the directory name, with and without the private flag.

Looked at the code a little bit and seems like it would have to be an issue with tr_metainfo_builder in makemeta.c

Attachments (1)

transmission-bug-714.tar (10.0 KB) - added by follicycle 14 years ago.
Files to Reproduce Bug

Download all attachments as: .zip

Change History (10)

comment:1 Changed 14 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

I can't reproduce this. I just created a couple of different torrent files with transmissioncli and it worked correctly. However the example command line usage given in your ticket doesn't work. Here's what I tried:

./transmissioncli -c /home/charles/Desktop/test -a http://tracker.bt/announce -r -m "This is my new torrent" test.torrent

comment:2 Changed 14 years ago by charles

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:3 Changed 14 years ago by charles

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:4 Changed 14 years ago by follicycle

  • Resolution worksforme deleted
  • Status changed from closed to reopened

"This is my new torrent" in the example command line is the name of a directory to be made into a torrent.

I will try with a full path and see if that works for me.

Changed 14 years ago by follicycle

Files to Reproduce Bug

comment:5 Changed 14 years ago by follicycle

When using a full path, torrent creation works for me.

Attached a test case with directory, script to create torrent with full path and without full path and the resulting torrent files showing successful and unsuccessful results.

comment:6 Changed 14 years ago by charles

  • Milestone changed from None Set to 1.10
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Summary changed from Filenames in Created Torrent Contain Last Character of Directory Name and / to makemeta creates invalid torrent files when given non-absolute pathnames

1.0x: r5084 trunk: r5085

Thanks for the extra information on how to reproduce this bug. :)

comment:7 Changed 14 years ago by charles

  • Milestone changed from 1.10 to 1.06

comment:8 Changed 14 years ago by charles

  • Summary changed from makemeta creates invalid torrent files when given non-absolute pathnames to makemeta breaks on non-absolute pathnames

comment:9 Changed 10 years ago by jordan

Xref: #4383

Note: See TracTickets for help on using tickets.