Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#727 closed Bug (fixed)

Setting download speed to 0 kills upload speed

Reported by: Taskman Owned by: charles
Priority: Normal Milestone: 1.10
Component: libtransmission Version: 1.05
Severity: Major Keywords:
Cc:

Description

Apparently, limiting a torrent's download speed to 0 KB/s (using the gear button) also prevents Transmission from uploading our data to other peers, as well as updating peer informations (such as their DL %) in the Peers tab of the Torrent Inspector.

This behaviour affects fresh torrents (0.00% downloaded), incomplete torrents (tested with 40.26% downloaded), and finished torrents (100% and seeding). Only noticed in the latest stable release of Transmission.

Attachments (3)

Immagine 1.jpg (29.3 KB) - added by Taskman 13 years ago.
Immagine 2.jpg (26.9 KB) - added by Taskman 13 years ago.
upload-from-0.png (44.4 KB) - added by charles 13 years ago.

Download all attachments as: .zip

Change History (14)

Changed 13 years ago by Taskman

Changed 13 years ago by Taskman

comment:1 Changed 13 years ago by charles

  • Component changed from Transmission to libtransmission
  • Milestone changed from None Set to 1.10
  • Owner set to charles
  • Status changed from new to assigned

confirmed. this holds true even when setting a seed's download speed to 0. :)

comment:2 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed 13 years ago by charles

  • Summary changed from Download speed setting also affects upload speed, peer informations in torrent inspector to Setting download speed to 0 kills upload speed

comment:4 Changed 13 years ago by Taskman

  • Resolution fixed deleted
  • Status changed from closed to reopened

An earlier nightly build fixed this problem, but now it appears to be there once again (5301).

comment:5 Changed 13 years ago by charles

confirmed, thanks for reporting this. (grumble ;)

comment:6 Changed 13 years ago by charles

  • Resolution set to worksforme
  • Status changed from reopened to closed

Hm, well Lacrocivious said this was confirmed, but I've tried three separate torrents now and can't reproduce it. Screenshot attached of me uploading at my (meager) full speed while the download speed is set to zero.

If this is a consistent problem for you I'm going to need some information on how to reproduce it. If it was an isolated thing it's possible that the peers at that time didn't want any of the pieces you'd downloaded before you turned off downloading.

Changed 13 years ago by charles

comment:7 Changed 13 years ago by charles

Taskman: actually, thinking about this some more... in cases where there are only a few peers, and they all have sent you blocks, turning your download speed to 0 is going to completely kill these connections because Transmission is going to refuse to read those downloaded blocks. And since those are queued up before any requests from those peers, the requests won't get read either.

In this kind of situation, you should be able to clear things up pretty easily by stopping and then restarting the torrent. That will delete the queues that had the partial blocks that the peers had sent to you.

comment:8 Changed 13 years ago by charles

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Reverting back to original "fixed" state to reflect the original bug's status

comment:9 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:10 Changed 13 years ago by charles

  • Severity changed from Normal to Major

comment:11 Changed 12 years ago by add

by end users who would like to contribute and start to use docs to learn cool stuff about their apps in the first place. Both annotations and contributions will only clutter the interface by default as a design pattern rather than trying to put it all together. That way you can never create offline or print docs of high quality without again having the devs or current admins maintain the comments and annotations. Hopefully a small Wiki quality team will evolve (i am against ops or admins) to review and summarize the contributions. I hope this gives us more users as contributors than having the docs focused on the devs. Cheers, duns china tour Apparel shoes bags Kitchen Food and Wine Furniture) Flowers and Gifts Wall Art Computer Components I still prefer a wiki like approach since the php (or mysql) docs are very cluttered when you have to take their comments in account. On the other hand they are professionally maintained imho, since they are *much* better than KDE documentation. KDE is by far larger and has so many different apps, which need screenshots and end user not dev/api docs

Note: See TracTickets for help on using tickets.