Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#771 closed Bug (fixed)

Segfault in strlcpy when trying to open a torrent

Reported by: jopadan Owned by: charles
Priority: High Milestone: 1.10
Component: GTK+ Client Version: 1.06
Severity: Critical Keywords:
Cc:

Description

Trying to open a torrent with current svn trunk transmission gtk client results in a segfault. I've attached a backtrace.

Attachments (1)

strlcpy-bt.txt (5.8 KB) - added by jopadan 14 years ago.
gdb backtrace of crash

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by jopadan

gdb backtrace of crash

comment:1 Changed 14 years ago by charles

  • Component changed from libtransmission to GTK+ Client
  • Milestone changed from None Set to 1.10
  • Resolution set to fixed
  • Status changed from new to closed
  • Version set to 1.06

comment:2 Changed 14 years ago by charles

  • Severity changed from Blocker to Critical

comment:3 Changed 14 years ago by charles

Looks like this was caused by not creating a default download directory. We were using g_get_user_special_dir(G_USER_DIRECTORY_DOWNLOAD) for this, but need to add a fallback in case that fails.

Note: See TracTickets for help on using tickets.