Opened 14 years ago

Closed 14 years ago

#783 closed Enhancement (wontfix)

Set share ratio to filesize/uploaded when entering seeding mode

Reported by: Taskman Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.06
Severity: Normal Keywords:
Cc:

Description

The share ratio for a given torrent is currently always calculated as DL/UL. This is okay for most situations, but will give funny results in certain cases, such as the one showed below (a few blocks fail validation and must be redownloaded).

Setting the share ratio to file size/uploaded whenever we enter seeding mode would most likely give a better result.

Attachments (2)

Immagine 1.png (50.7 KB) - added by Taskman 14 years ago.
Immagine 2.png (54.5 KB) - added by Taskman 14 years ago.

Download all attachments as: .zip

Change History (9)

Changed 14 years ago by Taskman

Changed 14 years ago by Taskman

comment:1 Changed 14 years ago by livings124

  • Component changed from Transmission to libtransmission
  • Owner set to charles

comment:2 Changed 14 years ago by charles

xref: #665

comment:3 Changed 14 years ago by charles

Setting the share ratio to (uploaded / torrent size) whenever seeding would give an inaccurate ratio if you've downloaded part of the torrent twice, and also if the user has chosen to not download part of the torrent.

IMO the better thing to do is to add the re-downloaded pieces to s->downloadedEver, which is usually what happens. Did you possibly remove & then re-add the torrent, losing the old `downloadedEver' statistics?

comment:4 Changed 14 years ago by Taskman

I haven't removed/re-added the torrent. I was really just missing that 9 KB.

A ratio based on selected/uploaded could be worth a shot, just to see how it would behave in real life.

The solution to the problem is probably a mix of the current and the alternative calculation method, I think.

comment:5 Changed 14 years ago by charles

what I don't understand is why your `downloaded' in screenshot #2 doesn't show (212.5 MB + 9 KB). Were you the original seeder on this torrent, s.t. 9 KB really *is* all you've ever downloaded?

If you downloaded this torrent originally, then your downloaded count should be 212.5 MB and your ratio should be correct.

comment:6 Changed 14 years ago by Taskman

I wasn't the original seeder, but I downloaded the file from a different source and joined the swarm.

Apparently, those 9 KB didn't validate and got redownloaded from the original seeder; after that, seeding started correctly.

comment:7 Changed 14 years ago by charles

  • Resolution set to wontfix
  • Status changed from new to closed

So, as far as the current tracker knows, all you've ever downloaded *is* 9 KB... :)

I agree that seeing a ratio of a zillion is odd, but I don't see a better alternative here. Saying that the solution is "a mix of the current and the alternative calculation method" doesn't address how Transmission would know when to switch over.

Note: See TracTickets for help on using tickets.