Opened 14 years ago

Closed 14 years ago

#785 closed Bug (fixed)

gtk/utils.c does not compile with glib 2.16 (trunk r5239)

Reported by: kman Owned by: charles
Priority: Normal Milestone: 1.10
Component: GTK+ Client Version:
Severity: Normal Keywords:
Cc:

Description

When using glib 2.16, transmission fails to compile with an undefined variable.

util.c: In function ‘tr_strlsize’:
util.c:80: error: ‘s’ undeclared (first use in this function)
util.c:80: error: (Each undeclared identifier is reported only once
util.c:80: error: for each function it appears in.)
make[2]: *** [util.o] Error 1
make[2]: Leaving directory `/home/kman/build/Transmission/gtk'

The problem is in the call to the function g_format_size_for_display. The code should be

char * tmp = g_format_size_for_display( size );

instead of

char * tmp = g_format_size_for_display( s );

This only applies to glib 2.16 since it is the only version which defines g_format_size_for_display.

Change History (2)

comment:1 Changed 14 years ago by kman

  • Summary changed from gtk/utils.c does not compile to gtk/utils.c does not compile with glib 2.16

comment:2 Changed 14 years ago by charles

  • Milestone changed from None Set to 1.10
  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from gtk/utils.c does not compile with glib 2.16 to gtk/utils.c does not compile with glib 2.16 (trunk r5239)
  • Version 1.06 deleted

fixed in r5240. Thanks!

Note: See TracTickets for help on using tickets.