Opened 13 years ago

Closed 13 years ago

#803 closed Bug (fixed)

Transmission loses too much unverified data when X crashes

Reported by: mshima Owned by: charles
Priority: Normal Milestone: 1.10
Component: libtransmission Version: 1.06
Severity: Normal Keywords:
Cc:

Description

Totem made my X crash and when I started transmission again it has lost ~300 MB of unverified data. I'm using transmission 1.06.

Change History (15)

comment:1 Changed 13 years ago by John Clay

What is "X", and have you tried a nightly build if on OS X, or recent source?

comment:2 Changed 13 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #698, which is marked as fixed for 1.10

comment:3 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.10
  • Summary changed from Transmission looses too much unverified data when X crashes to Transmission loses too much unverified data when X crashes

comment:4 Changed 13 years ago by charles

John_Clay: X is the low-level graphical library that Linux uses, so it's unlikely that he's using OS X. ;)

comment:5 Changed 13 years ago by mshima

  • Resolution duplicate deleted
  • Status changed from closed to reopened

This bug don't seems duplicate to me. Bug #698 is about to much unverified data. My problem is that I lost unverified data on a system crash. But surely fixing #698 will make #803 less visible, since we will have less unverified data.

X (Xorg) is the linux graphical interface.

I'm reopening this bug.

comment:6 Changed 13 years ago by livings124

  • Resolution set to duplicate
  • Status changed from reopened to closed

If your system crashes, unverified data will be lost. I think the bigger concern is to not having another app crash your system. #698 attempts to make the amount of unverified data smaller, which is the best solution.

comment:7 Changed 13 years ago by mshima

What about call saveFastResumeNow or fastResumeSave once every 2 or 3 minutes?? I didn't loose all unverified data, seams that I've lost all data in a period of time.

comment:8 Changed 13 years ago by mshima

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Reopening to get attention to my last comment.

comment:9 Changed 13 years ago by livings124

  • Resolution set to worksforme
  • Status changed from reopened to closed

If you still see this as a big issue after 1.10 is released, then reopen it.

comment:10 Changed 13 years ago by charles

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:11 Changed 13 years ago by charles

  • Owner set to charles
  • Status changed from reopened to new

comment:12 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed

comment:13 Changed 13 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:14 Changed 13 years ago by charles

  • Component changed from Transmission to libtransmission

comment:15 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.