Opened 14 years ago

Closed 14 years ago

#804 closed Enhancement (wontfix)

Set priorities & download flag for multiple files at once

Reported by: pcastell Owned by: charles
Priority: Normal Milestone: Sometime
Component: GTK+ Client Version: 1.06
Severity: Normal Keywords:
Cc:

Description

I wish to see the following GTK+ client enhancements in a future Transmission release:

  • Main window, it should display the ETA per torrent
  • Details window, Info tab, the torrent hash should be selectable (for copy/paste and to use it in search engines)
  • Details window, Files tab, it will be very helpfull the ability to operate on multiple files at once, i.e. to change the priorty or the download flag in many files at the same time.
  • The ability to limit the number of torrents to download/seed at once and some way to choose wich one first

Change History (3)

comment:1 Changed 14 years ago by charles

  • Milestone changed from None Set to 1.10
  • Status changed from new to assigned
Main window, it should display the ETA per torrent

Already done for 1.10

Details window, Info tab, the torrent hash should be selectable (for copy/paste and to use it in search engines)

This is a good idea, and something we can do for 1.10

Details window, Files tab, it will be very helpfull the ability to operate on multiple files at once, i.e. to change the priorty or the download flag in many files at the same time. 

This is a good idea, but it would probably require adding a right-click menu from selections... slating this part for 1.20 because of the 1.10 freeze.

The ability to limit the number of torrents to download/seed at once and some way to choose wich one first

This is a duplicate of #671

comment:2 Changed 14 years ago by charles

  • Milestone changed from 1.10 to 1.20
  • Summary changed from GTK+ Client Enhancements to Set priorities & download flag for multiple files at once

r5320: the torrent hash is now selectable.

The remaining part of this ticket (the files tab part) is, as I said, not going to get past the 1.10 freeze. Updating the ticket accordingly...

comment:3 Changed 14 years ago by charles

  • Milestone changed from 1.20 to Sometime
  • Resolution set to wontfix
  • Status changed from assigned to closed

I can't think of a good way to do this, and all the half-attempts I've tried have complicated the code without making things particularly more usable.

If someone wants to make a mockup or a patch of how this should be done, that would be fine. I'm going to let this ticket slide until then.

Note: See TracTickets for help on using tickets.