Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#848 closed Enhancement (fixed)

upnp starts slowly because it waits for nat-pmp to fail first

Reported by: dargol Owned by: charles
Priority: Normal Milestone: 1.20
Component: libtransmission Version: 1.11
Severity: Normal Keywords:
Cc:

Description

Hi as sugested in the forum

xenedar said:

Is there a way (or could you add a way) for Transmission to try UPnP first, before NAT-PMP? >Sitting there for 2 minutes waiting for it to figure out, again, that my router doesn't support >NAT-PMP is annoying.

Suggestions:

  • a pop-up in Advanced labelled "Try first:", with options NAT-PMP and UPnP.
  • Transmission remembers what worked correctly last time, and automatically tries that first >the next time (the odds are that it's talking to the same router again).
  • is there any wiggle room for the timeout? If a router does support NAT-PMP, should it >actually require up to 2 minutes to map? I mean UPnP only takes a few seconds to do it (once >Transmission kicks it in), so would 15 seconds be plenty? (I have no actual experience with >NAT-PMP.)

This was intended for the mac version but I am a gtk user and it would be great to have this!

Change History (4)

comment:1 Changed 14 years ago by charles

  • Component changed from Transmission to libtransmission
  • Milestone changed from None Set to 1.20
  • Owner set to charles
  • Status changed from new to assigned
  • Version changed from 1.10 to 1.11

comment:2 Changed 14 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r5600. Thanks for the suggestion.

comment:3 Changed 14 years ago by charles

As an aside, this also fixes the log messages that confused so many users:

13:31:59 Port Mapping (NAT-PMP): readnatpmpresponseorretry returned error -7, errno is 111 (Connection refused) 13:31:59 Port Mapping (NAT-PMP): If your router supports NAT-PMP, please make sure NAT-PMP is enabled! 13:31:59 Port Mapping (NAT-PMP): NAT-PMP port forwarding unsuccessful, trying UPnP next

comment:4 Changed 14 years ago by charles

  • Summary changed from Prefer UPnP to upnp starts slowly because it waits for nat-pmp to fail first
Note: See TracTickets for help on using tickets.