Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#866 closed Bug (fixed)

crash when adding a new torrent

Reported by: dggonz Owned by: charles
Priority: Normal Milestone: 1.20
Component: GTK+ Client Version: 1.11
Severity: Blocker Keywords:
Cc:

Description

Since a week or so the SVN TRUNK version crash consistently when trying to add any torrent. The crash happends right after the transmission is trying to show the window with the different files inside the torrent. Here is the backtrace and the message i get on the console:

transmission: utils.c:857: strlcpy: Assertion `s != ((void *)0)' failed.

(gdb) bt #0 0xb7f8c410 in kernel_vsyscall () #1 0xb75eaef5 in raise () from /lib/i686/cmov/libc.so.6 #2 0xb75ec871 in abort () from /lib/i686/cmov/libc.so.6 #3 0xb75e40ee in assert_fail () from /lib/i686/cmov/libc.so.6 #4 0x0808d68c in strlcpy (dst=0x0, src=0x0, siz=1024) at utils.c:857 #5 0x0805e7f7 in sourceChanged (b=0x819a390, gdata=0x82bf448)

at add-dialog.c:96

#6 0xb79df69b in IAg_cclosure_marshal_VOIDVOID (closure=0x82bc3d0,

return_value=0x0, n_param_values=1, param_values=0xbf8ae27c, invocation_hint=0xbf8ae0f0, marshal_data=0x0) at gmarshal.c:77

#7 0xb79c8371 in IAg_closure_invoke (closure=0x82bc3d0, return_value=0x0,

n_param_values=1, param_values=0xbf8ae27c, invocation_hint=0xbf8ae0f0) at gclosure.c:490

#8 0xb79deb62 in signal_emit_unlocked_R (node=0x8208ad0, detail=0,

instance=0x819a390, emission_return=0x0, instance_and_params=0xbf8ae27c) at gsignal.c:2440

#9 0xb79ddd79 in IAg_signal_emit_valist (instance=0x819a390, signal_id=212,

detail=0, var_args=0xbf8ae488 "\030O\f\b\030O\f\b�\223\f\b@\227\237�\030�\031\b\233�\235��� \b\220�\031\b��\212�+\207\220�\002") at gsignal.c:2199

#10 0xb79de21b in IAg_signal_emit_by_name (instance=0x819a390,

detailed_signal=0xb7e0c67d "selection-changed") at gsignal.c:2267

#11 0xb7c6a97c in ?? () from /usr/lib/libgtk-x11-2.0.so.0 ---Type <return> to continue, or q <return> to quit--- #12 0x0819a390 in ?? () #13 0xb7e0c67d in ?? () from /usr/lib/libgtk-x11-2.0.so.0 #14 0x080c4f18 in ?? () #15 0x080c4f18 in ?? () #16 0x080c93a8 in ?? () #17 0xb79f9740 in ?? () from /usr/lib/libgobject-2.0.so.0 #18 0x0819ee18 in ?? () #19 0xb79df69b in IAg_cclosure_marshal_VOIDVOID (closure=0x81a25a8,

return_value=0x0, n_param_values=1, param_values=0xbf8ae7fc, invocation_hint=0xbf8ae670, marshal_data=0x0) at gmarshal.c:77

#20 0xb79c8371 in IAg_closure_invoke (closure=0x81a25a8, return_value=0x0,

n_param_values=1, param_values=0xbf8ae7fc, invocation_hint=0xbf8ae670) at gclosure.c:490

#21 0xb79deb62 in signal_emit_unlocked_R (node=0x8208ad0, detail=0,

instance=0x820eab0, emission_return=0x0, instance_and_params=0xbf8ae7fc) at gsignal.c:2440

#22 0xb79ddd79 in IAg_signal_emit_valist (instance=0x820eab0, signal_id=212,

detail=0, var_args=0xbf8aea08 "\002") at gsignal.c:2199

#23 0xb79de21b in IAg_signal_emit_by_name (instance=0x820eab0,

detailed_signal=0xb7e0c67d "selection-changed") at gsignal.c:2267

#24 0xb7c7bf6b in ?? () from /usr/lib/libgtk-x11-2.0.so.0 #25 0x0820eab0 in ?? () #26 0xb7e0c67d in ?? () from /usr/lib/libgtk-x11-2.0.so.0 #27 0x00000002 in ?? () #28 0x0820f518 in ?? () #29 0x080c93a8 in ?? () #30 0xb7c7bf52 in ?? () from /usr/lib/libgtk-x11-2.0.so.0 #31 0xb79f9740 in ?? () from /usr/lib/libgobject-2.0.so.0 #32 0xb79df69b in IAg_cclosure_marshal_VOIDVOID (closure=0x82dd4c8,

return_value=0x0, n_param_values=1, param_values=0xbf8aed7c, invocation_hint=0xbf8aebf0, marshal_data=0x0) at gmarshal.c:77

#33 0xb79c8371 in IAg_closure_invoke (closure=0x82dd4c8, return_value=0x0,

n_param_values=1, param_values=0xbf8aed7c, invocation_hint=0xbf8aebf0) at gclosure.c:490

#34 0xb79deb62 in signal_emit_unlocked_R (node=0x8208ad0, detail=0,

instance=0x8155b18, emission_return=0x0, instance_and_params=0xbf8aed7c) at gsignal.c:2440

#35 0xb79ddd79 in IAg_signal_emit_valist (instance=0x8155b18, signal_id=212,

detail=0, var_args=0xbf8aef88 "\002") at gsignal.c:2199

#36 0xb79de21b in IAg_signal_emit_by_name (instance=0x8155b18,

detailed_signal=0xb7e0c67d "selection-changed") at gsignal.c:2267

#37 0xb7c7bf6b in ?? () from /usr/lib/libgtk-x11-2.0.so.0 #38 0x08155b18 in ?? () #39 0xb7e0c67d in ?? () from /usr/lib/libgtk-x11-2.0.so.0 #40 0x00000002 in ?? () #41 0xb79ce8a9 in IAg_object_unref (_object=0x82d5090) at gobject.c:1755 ---Type <return> to continue, or q <return> to quit--- #42 0xb79c8371 in IAg_closure_invoke (closure=0x82d5090, return_value=0x0,

n_param_values=1, param_values=0xbf8af2fc, invocation_hint=0xbf8af170) at gclosure.c:490

#43 0xb79deb62 in signal_emit_unlocked_R (node=0x8208ad0, detail=0,

instance=0x8212200, emission_return=0x0, instance_and_params=0xbf8af2fc) at gsignal.c:2440

#44 0xb79ddd79 in IAg_signal_emit_valist (instance=0x8212200, signal_id=212,

detail=0, var_args=0xbf8af508 "") at gsignal.c:2199

#45 0xb79de21b in IAg_signal_emit_by_name (instance=0x8212200,

detailed_signal=0xb7e0c67d "selection-changed") at gsignal.c:2267

#46 0xb7c75ef2 in ?? () from /usr/lib/libgtk-x11-2.0.so.0 #47 0x08212200 in ?? () #48 0xb7e0c67d in ?? () from /usr/lib/libgtk-x11-2.0.so.0 #49 0x00000000 in ?? ()

The symbols in GTK are missing, if you need a backtrace with them let me know and i will recompile GKT+ with them.

Attachments (1)

p (4.7 KB) - added by dggonz 9 years ago.
this is a text file with the backtrace, hope it is cleaner than the C&P version on the bug body

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by dggonz

  • Attachment p added

this is a text file with the backtrace, hope it is cleaner than the C&P version on the bug body

comment:1 Changed 9 years ago by charles

  • Milestone changed from None Set to 1.20
  • Status changed from new to assigned

comment:2 Changed 9 years ago by charles

dggonz: please try svn r5604 or higher and see if that fixes things. I'm not able to reproduce this error, so I need your help. :)

If it *does* crash, please attach a new backtrace and the revision number. Thanks!

comment:3 Changed 9 years ago by charles

also: what version of gtk+ do you have installed?

comment:4 Changed 9 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

I can't get this to crash no matter what I try. Marking as `fixed'. Feel free to reopen if needed.

comment:5 Changed 8 years ago by add

(deleted spam)

Last edited 7 years ago by charles (previous) (diff)

comment:6 Changed 7 years ago by sim

decoration Changed 1 year ago by admin

bathtub Changed 1 year ago by admin

solar system Changed 1 year ago by admin

stair parts Changed 1 year ago by admin

solar supply Changed 1 year ago by admin

Version 0, edited 7 years ago by sim (next)
Note: See TracTickets for help on using tickets.