Opened 14 years ago

Closed 14 years ago

#877 closed Bug (invalid)

configure fails if pkg-config not present

Reported by: KyleK Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.11
Severity: Normal Keywords:
Cc:

Description

the configure script fails if pkg-config is not present on the system, even if the user provided the OPENSSL_CFLAGS and OPENSSL_LIBS options to configure. Looking at the configure script, both flags are only used if the variable $PKGCONFIG contains a value.

Expected behaviour: configure should use the values provided by both OPENSSL_ options if pkg-config is too old or not present at all.

Change History (3)

comment:1 Changed 14 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Unless you can show me where Transmission is using pkg-config incorrectly, this is not a Transmission bug.

If pkg-config's autoconf macro needs to handle "test -n $PKG_CONFIG" more elegantly, you need to report that bug upstream.

related librtorrent ticket

comment:2 Changed 14 years ago by KyleK

  • Resolution invalid deleted
  • Status changed from closed to reopened

If configure fails because it cannot locate OpenSSL libraries, this message appears: "Alternatively, you may set the environment variables OPENSSL_CFLAGS and OPENSSL_LIBS to avoid the need to call pkg-config." But, looking at the code, OPENSSL_CFLAGS & OPENSSL_LIBS is only ever used if pkg-config is found on the system:

if test -n "$PKG_CONFIG"; then
   if test -n "$OPENSSL_CFLAGS"; then
      pkg_cv_OPENSSL_CFLAGS="$OPENSSL_CFLAGS"
   else
     ($PKG_CONFIG --exists --print-errors "openssl >= 0.9.4") 2>&5
   fi
else
  pkg_failed=yes
fi

The $PKG_CONFIG variable is empty in my case, so the script fails. I can work around this by manually modifying the configure script, but this shouldn't be necessary.

comment:3 Changed 14 years ago by charles

  • Resolution set to invalid
  • Status changed from reopened to closed

I don't think you read my comment above. That section of the configure script is generated by pkg-config's autoconf macro, so that bug needs to be reported upstream.

This isn't a Transmission bug unless you can show me where Transmission is using pkg-config incorrectly.

Note: See TracTickets for help on using tickets.