Opened 14 years ago

Closed 14 years ago

#904 closed Bug (fixed)

crash on startup in tr_bitfieldHas

Reported by: charles Owned by: charles
Priority: Normal Milestone: 1.20
Component: libtransmission Version: 1.11
Severity: Major Keywords:
Cc:

Description

http://forum.transmissionbt.com/viewtopic.php?t=4726

Version: 1.11+ (5713)
Code Type: X86 (Native)
Parent Process: launchd [124]

Date/Time: 2008-04-28 09:37:11.377 -0400
OS Version: Mac OS X 10.5.2 (9C7010)
Report Version: 6

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000146ef000
Crashed Thread: 0

Thread 0 Crashed:
0 org.m0k.transmission 0x0004b157 tr_bitfieldHas + 45
1 org.m0k.transmission 0x00058db2 tr_cpBlockBitfieldSet + 172
2 org.m0k.transmission 0x0005d268 tr_fastResumeLoad + 1402
3 org.m0k.transmission 0x0006be05 tr_torrentLoadResume + 233
4 org.m0k.transmission 0x00051a38 tr_torrentNew + 1521 

Change History (3)

comment:1 Changed 14 years ago by charles

  • Status changed from new to assigned

comment:2 Changed 14 years ago by charles

This appears to be due to a corrupt resume file. Judging from the thread, it may have been truncated due to the disk being full.

Possible fix: r5720

comment:3 Changed 14 years ago by livings124

  • Resolution set to fixed
  • Status changed from assigned to closed

Confirmed fixed in the thread.

Note: See TracTickets for help on using tickets.