Opened 14 years ago

Closed 14 years ago

#919 closed Bug (duplicate)

Bandwidth limits are not correctly enforced

Reported by: tgos Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.11
Severity: Normal Keywords:
Cc:

Description

I have been using Bits on Wheels so far. It's quite outdated, no development in 3 years, but if there's one thing it's good at, it's enforcing bandwidth limits!

When I have 4 seeding torrents and 3 downloading torrents and I set the upload limit to 40 KB/s, MenuMeters? shows that the traffic leaving my interface is between 60 and 80 KB/s. When I set 40 KB/s in BoW, MenuMeters? shows between 39 and 41 KB/s being sent.

Either the bandwidth enforcement is seriously broken (and yes, I'm using the very latest downloadable version, 1.11) or it is broken by design, as it ignores protocol overhead and it ignores the fact that downloads cause upload traffic, too. BoW was taking all that into account.

When I have no downloads, only seeds, the bandwidth is still between 40 and 50 KB/s, although 40 KB/s are configured.

Transmission always says it's just using 40 KB/s, but in fact it's always using more, making the whole feature useless and thus making the whole client useless for me. I share my Internet bandwidth with other users and I need to rely on the fact that the client does not use more of our shared bandwidth than I have configured under any circumstances.

It looks like any kind of protocol overhead is never taken into account and overhead caused by downloads (protocol, but also requests and confirmation packages) is never taken into account, too.

Other clients take all this into account correctly when throttling bandwidth, Activity Monitor as well as MenuMeters? always show exactly the correct results, just not for Transmission and I trust these tools much more to show the correct values than I trust the transmission bandwidth indicator.

Change History (1)

comment:1 Changed 14 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #617

Note: See TracTickets for help on using tickets.