Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#973 closed Bug (worksforme)

Tracker handling code crashes while adding torrents

Reported by: trisk Owned by: charles
Priority: High Milestone: 1.30
Component: libtransmission Version: 1.22+
Severity: Major Keywords:
Cc:

Description

I started a new transmission-daemon session and added 74 torrents with transmission-remote. transmission-daemon crashed before responding to the client.

trackerSupportsScrape dereferences a NULL pointer (to compare its value to 8).

Here's the stack at the time:

current thread: t@2
=>[1] trackerSupportsScrape(0x8101ee8, 0x80ff328), at 0x80666b4 
  [2] tr_trackerNew(0x80ff328), at 0x806779e 
  [3] torrentRealInit(0x80a6ac8, 0x80ff328, 0x80ea890), at 0x806454d 
  [4] tr_torrentNew(0x80a6ac8, 0x80ea890, 0xfee49be4), at 0x80647f5 
  [5] torrentAdd(0x80a6ac8, 0x80aef98, 0x80aef10), at 0x807b6ce 
  [6] request_exec(0x80a6ac8, 0xfee49c60, 0xfee49cb8), at 0x807bb1d 
  [7] tr_rpc_request_exec_json(0x80a6ac8, 0x80ca888, 0x179d5, 0xfee49cb8), at 0x807bbe1 
  [8] handle_rpc(0xfee49cf8), at 0x8074f19 
  [9] call_user(0x80c2670, 0xfee49cf8, 0x8074e5c), at 0x8081dc5 
  [10] do_embedded(0x80c2730, 0x80c27a8, 0x4000), at 0x8081e53 
  [11] read_stream(0x80c2730), at 0x807f3ef 
  [12] process_connection(0x80c2670, 0x1, 0x40), at 0x807f70a 
  [13] shttpd_poll(0x80aee18, 0x1), at 0x807fb04 
  [14] rpcPulse(0xffffffff, 0x1, 0x80b11b0), at 0x8074fc8 
  [15] event_base_loop(0x80a7210, 0x0), at 0x80862fc 
  [16] event_loop(0x0), at 0x8085f74 
  [17] event_dispatch(0x80a6b58, 0x808c4d4, 0x808b860, 0x7f, 0x3, 0xfee49fcc), at 0x8085e81 
  [18] libeventThreadFunc(0x80a71a0, 0x0, 0xfed30200, 0xfef95000, 0x10, 0x400), at 0x8067cea 
  [19] ThreadFunc(0x80a6b58), at 0x80619b0 
  [20] _thr_setup(0xfed30200), at 0xfef4ce82 
  [21] _lwp_start(), at 0xfef4d0e0 

I'll update this as I get more information.

Change History (6)

comment:1 Changed 14 years ago by charles

I can't reproduce this. Can you attach the torrent which crashed Transmission here, or DCC it to me in IRC?

comment:2 Changed 14 years ago by charles

Still waiting on more info about this...

comment:3 Changed 14 years ago by charles

  • Resolution set to worksforme
  • Status changed from new to closed

10:40 <@charles_> Triskelios: also, did you have more for me on #973? 10:41 < Triskelios> charles_: I couldn't reproduce it after an svn update about 2 days ago

comment:4 Changed 14 years ago by trisk

I can confirm this was fixed between r5926 and r5986. The torrent I tested with was LegalTorrents?' wired-creative-commons-cd.torrent.

comment:5 Changed 14 years ago by charles

  • Version 1.21 deleted

comment:6 Changed 14 years ago by charles

  • Version set to 1.22+
Note: See TracTickets for help on using tickets.