Opened 10 years ago

Closed 9 years ago

#996 closed Enhancement (fixed)

The statusbar should be on bottom in the Gtk+ UI

Reported by: paobac Owned by: charles
Priority: Low Milestone: 1.50
Component: GTK+ Client Version: 1.21
Severity: Normal Keywords: usability hig
Cc:

Description

I think the statusbar should be on the bottom of the main window, and the scroll window should have a shadow. I'm going to provide a patch for these two changes.

Attachments (1)

statusbar-at-bottom-and-list-shadow.patch (1.3 KB) - added by paobac 10 years ago.
to apply cd to Transmission and enter: patch -p2 < statusbar-at-bottom-and-list-shadow.patch

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by paobac

to apply cd to Transmission and enter: patch -p2 < statusbar-at-bottom-and-list-shadow.patch

comment:1 Changed 10 years ago by paobac

  • Component changed from Transmission to GTK+ Client
  • Owner set to charles
  • Priority changed from Normal to Low

comment:2 Changed 10 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

Thank you for the patch, but this is a duplicate of #632.

The reason I keep the statusbar near the top is so that it's easier to see which filter is applied, and the number of visible torrents, at a glance instead of having to look up and down to the top and bottom of the window.

comment:3 Changed 10 years ago by charles

  • Milestone changed from None Set to 1.50
  • Resolution duplicate deleted
  • Status changed from closed to reopened

I'm reopening this ticket because the Gnome HIG is explicit about statusbar placement:

"Only place a statusbar along the bottom of a window."

comment:4 Changed 10 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

changed in r7118.

comment:5 Changed 10 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

I hate, hate, hate having the speed controls on the bottom. They are impossible to see there.

comment:6 Changed 10 years ago by kiddo

  • Cc thibault.bethune added
  • Keywords usability added

I don't really know what's the status of this, but I'll comment to add my 2 cents/balance just to make sure.

This is a matter of habit. To rephrase your example, I hate, hate, hate having 3 layers of "stuff" (2 toolbars, 1 statusbar) on top of each other. The UI looks unbalanced at best. And it goes directly against the human design rules of GNOME. Just like the bunch of rules in the mac environment, you should conform to those from the gnome environment. The HIG says at the bottom, nowhere else. Now when every other gnome app starts putting statusbars in the middle of their windows, then we'll see ;)

As a counterbalance to your experience, I personally have much less difficulty seeing those speeds when they are at the bottom, because they ain't crammed together with a bunch of other UI components. Actually, the statusbar being at the bottom would mean that I could *actually* show it (leave it on), instead of toggling it off because it of the clutter at the top of the UI.

Regarding the argument you brought in #632: why would you care about the number of matches when doing a search-as-you-type? I don't even know why this number needs to be there in a status bar. What does it matter if one has 4 torrents or 653, or that I had "4 matches out of 7 total torrents"? I mean, we can see them directly being matched in the viewport area, so why care about their number? (this is not intended as an insult, it's a question. I don't see the usefulness in "counting the torrents" from a user's point of view)

comment:7 Changed 10 years ago by kiddo

  • Cc thibault.bethune removed

comment:8 Changed 10 years ago by charles

Well, I've left it assigned and slated for 1.50, because I agree that the Gnome HIG overrules my personal preferences. Probably I'll make a settings option for its location, :)

comment:10 Changed 9 years ago by charles

  • Keywords hig added
  • Resolution set to fixed
  • Status changed from reopened to closed

Added to trunk in r7502

Note: See TracTickets for help on using tickets.